unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#47978: guix/import/go.scm: Dependency on guile-lib >= 0.2.7
@ 2021-04-23 18:50 Vagrant Cascadian
  2021-04-28 21:35 ` Ludovic Courtès
  0 siblings, 1 reply; 3+ messages in thread
From: Vagrant Cascadian @ 2021-04-23 18:50 UTC (permalink / raw)
  To: 47978

[-- Attachment #1: Type: text/plain, Size: 1107 bytes --]

When building guix (with commit cb3f9696f6251ad382febad33290fed929c176b4
from branch version-1.3.0) on Debian, it fails with the following error
with guile-library (a.k.a. guile-lib) version 0.2.6.1-2:

  ice-9/eval.scm:293:34: error: %strict-tokenizer?: unbound variable
  hint: Did you forget a `use-modules' form?

  [ 10%] LOAD     guix/import/go.scm
  ;;; Failed to autoload semver-range-contains? in (semver ranges):
  ;;; missing interface for module (semver ranges)
 ...
  ;;; Failed to autoload semver<? in (semver):
  ;;; missing interface for module (semver)
  ice-9/eval.scm:293:34: error: %strict-tokenizer?: unbound variable
  hint: Did you forget a `use-modules' form?


Installing guile-library version 0.2.7 works fine.

FWIW, I do not have guile-semver installed in either case; that seems to
be a truely optional dependency... guile-semver is not yet accepted in
Debian, but hopefully will be soon:

  https://ftp-master.debian.org/new/guile-semver_0.1.1-1.html


Maybe doc/guix.texi should be updated to specify the minimum version?


live well,
  vagrant

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 227 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#47978: guix/import/go.scm: Dependency on guile-lib >= 0.2.7
  2021-04-23 18:50 bug#47978: guix/import/go.scm: Dependency on guile-lib >= 0.2.7 Vagrant Cascadian
@ 2021-04-28 21:35 ` Ludovic Courtès
  2021-04-28 22:29   ` Vagrant Cascadian
  0 siblings, 1 reply; 3+ messages in thread
From: Ludovic Courtès @ 2021-04-28 21:35 UTC (permalink / raw)
  To: Vagrant Cascadian; +Cc: 47978

Hi,

Vagrant Cascadian <vagrant@debian.org> skribis:

> When building guix (with commit cb3f9696f6251ad382febad33290fed929c176b4
> from branch version-1.3.0) on Debian, it fails with the following error
> with guile-library (a.k.a. guile-lib) version 0.2.6.1-2:
>
>   ice-9/eval.scm:293:34: error: %strict-tokenizer?: unbound variable
>   hint: Did you forget a `use-modules' form?
>
>   [ 10%] LOAD     guix/import/go.scm
>   ;;; Failed to autoload semver-range-contains? in (semver ranges):
>   ;;; missing interface for module (semver ranges)
>  ...
>   ;;; Failed to autoload semver<? in (semver):
>   ;;; missing interface for module (semver)
>   ice-9/eval.scm:293:34: error: %strict-tokenizer?: unbound variable
>   hint: Did you forget a `use-modules' form?
>
>
> Installing guile-library version 0.2.7 works fine.

34db952a4b655cca9d5dc7158e9a8552d389cbcf fixes it by making Guile-Lib a
“soft” dependency as was intended.  But yes, 0.2.7 is required if you
want to use ‘guix import go’.

Thanks,
Ludo’.




^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#47978: guix/import/go.scm: Dependency on guile-lib >= 0.2.7
  2021-04-28 21:35 ` Ludovic Courtès
@ 2021-04-28 22:29   ` Vagrant Cascadian
  0 siblings, 0 replies; 3+ messages in thread
From: Vagrant Cascadian @ 2021-04-28 22:29 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 47978

[-- Attachment #1: Type: text/plain, Size: 1320 bytes --]

On 2021-04-28, Ludovic Courtès wrote:
> Vagrant Cascadian <vagrant@debian.org> skribis:
>
>> When building guix (with commit cb3f9696f6251ad382febad33290fed929c176b4
>> from branch version-1.3.0) on Debian, it fails with the following error
>> with guile-library (a.k.a. guile-lib) version 0.2.6.1-2:
>>
>>   ice-9/eval.scm:293:34: error: %strict-tokenizer?: unbound variable
>>   hint: Did you forget a `use-modules' form?
>>
>>   [ 10%] LOAD     guix/import/go.scm
>>   ;;; Failed to autoload semver-range-contains? in (semver ranges):
>>   ;;; missing interface for module (semver ranges)
>>  ...
>>   ;;; Failed to autoload semver<? in (semver):
>>   ;;; missing interface for module (semver)
>>   ice-9/eval.scm:293:34: error: %strict-tokenizer?: unbound variable
>>   hint: Did you forget a `use-modules' form?
>>
>>
>> Installing guile-library version 0.2.7 works fine.
>
> 34db952a4b655cca9d5dc7158e9a8552d389cbcf fixes it by making Guile-Lib a
> “soft” dependency as was intended.  But yes, 0.2.7 is required if you
> want to use ‘guix import go’.

Makes sense.

Some (e.g. guile-ssh) of the "optional" dependencies are or were
similarly required to build guix in the past ... I should probably file
bugs when I encounter them, sounds like. :)


live well,
  vagrant

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 227 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-04-28 22:31 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-23 18:50 bug#47978: guix/import/go.scm: Dependency on guile-lib >= 0.2.7 Vagrant Cascadian
2021-04-28 21:35 ` Ludovic Courtès
2021-04-28 22:29   ` Vagrant Cascadian

unofficial mirror of bug-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-bugs/0 guix-bugs/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-bugs guix-bugs/ https://yhetil.org/guix-bugs \
		bug-guix@gnu.org
	public-inbox-index guix-bugs

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.bugs
	nntp://news.gmane.io/gmane.comp.gnu.guix.bugs


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git