unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#48796: Guix on Debian 11 - Cant run or find applications from Guix
@ 2021-06-02 18:56 bo0od
  2021-06-03 21:26 ` Maxime Devos
  2021-06-05 17:49 ` Mark H Weaver
  0 siblings, 2 replies; 7+ messages in thread
From: bo0od @ 2021-06-02 18:56 UTC (permalink / raw)
  To: 48796

Hi There,

I have installed Guix package manager over debian bullseye 11 then i 
installed a package using guix (after running guix pull) with two ways: 
(x package i tried is icecat)

guix install x

sudo -i guix install x

both of the commands worked but the x package has no icon nor i can run 
it using terminal.


ThX!




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#48796: Guix on Debian 11 - Cant run or find applications from Guix
  2021-06-02 18:56 bug#48796: Guix on Debian 11 - Cant run or find applications from Guix bo0od
@ 2021-06-03 21:26 ` Maxime Devos
  2021-06-03 23:18   ` bo0od
  2021-06-05 17:49 ` Mark H Weaver
  1 sibling, 1 reply; 7+ messages in thread
From: Maxime Devos @ 2021-06-03 21:26 UTC (permalink / raw)
  To: bo0od, 48796

[-- Attachment #1: Type: text/plain, Size: 1215 bytes --]

bo0od schreef op wo 02-06-2021 om 18:56 [+0000]:
> Hi There,
> 
> I have installed Guix package manager over debian bullseye 11 then i 
> installed a package using guix (after running guix pull) with two ways: 
> (x package i tried is icecat)
> 
> guix install x
> 
> sudo -i guix install x

There should be no need to install anything as root,
unless you make a habit of logging in as the root user
and work from there (not recommended).

(Except the guix daemon itself maybe? But that's "sudo guix pull"
I think, not "sudo guix install guix". I'm on Guix System
myself.)

> both of the commands worked but the x package has no icon nor i can run 
> it using terminal.

Which icon are you looking at? The icon in a desktop menu?
The ‘cat around a globe’ image you'd see on ‘new tab’ windows
above the search bar? The same image, but downscaled, before
‘New Tab’ in the tab bar?

> nor i can run it using terminal

I can use IceCat just fine from the terminal (Guix System),
more details are needed, ‘I can't run it’ is rather vague.
Is there any log output, does IceCat start but crash soon,
maybe ‘bash: icecat: command not found’, ...?

Greetings,
Maxime.

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 260 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#48796: Guix on Debian 11 - Cant run or find applications from Guix
  2021-06-03 21:26 ` Maxime Devos
@ 2021-06-03 23:18   ` bo0od
  2021-06-05  9:47     ` Maxime Devos
  0 siblings, 1 reply; 7+ messages in thread
From: bo0od @ 2021-06-03 23:18 UTC (permalink / raw)
  To: Maxime Devos, 48796

 > There should be no need to install anything as root,
 > unless you make a habit of logging in as the root user
 > and work from there (not recommended).

I know i just mentioned this info to say with or without root nothing is 
appeared to be readable from the system.

 > Which icon are you looking at? The icon in a desktop menu?
 > The ‘cat around a globe’ image you'd see on ‘new tab’ windows
 > above the search bar? The same image, but downscaled, before
 > ‘New Tab’ in the tab bar?

There is nothing exist of any kind from icons. (icecat starting icon in 
the applications menu or so)

 > I can use IceCat just fine from the terminal (Guix System),
 > more details are needed, ‘I can't run it’ is rather vague.
 > Is there any log output, does IceCat start but crash soon,

I can use that as well fine in guixsd, But not in debian.

 > maybe ‘bash: icecat: command not found’, ...?

yes, and if i type ice and press Tab nothing appearing.

So whether graphical or terminal nothing indicating that there is a 
software installed/exist in the system (though the software installed 
and exist)

Note:

manually going to 
/home/user/.guix-profile/share/applications/icecat.desktop and pressing 
it it will run icecat.(but thats not how applications should be running)


Maxime Devos:
> bo0od schreef op wo 02-06-2021 om 18:56 [+0000]:
>> Hi There,
>>
>> I have installed Guix package manager over debian bullseye 11 then i
>> installed a package using guix (after running guix pull) with two ways:
>> (x package i tried is icecat)
>>
>> guix install x
>>
>> sudo -i guix install x
> 
> There should be no need to install anything as root,
> unless you make a habit of logging in as the root user
> and work from there (not recommended).
> 
> (Except the guix daemon itself maybe? But that's "sudo guix pull"
> I think, not "sudo guix install guix". I'm on Guix System
> myself.)
> 
>> both of the commands worked but the x package has no icon nor i can run
>> it using terminal.
> 
> Which icon are you looking at? The icon in a desktop menu?
> The ‘cat around a globe’ image you'd see on ‘new tab’ windows
> above the search bar? The same image, but downscaled, before
> ‘New Tab’ in the tab bar?
> 
>> nor i can run it using terminal
> 
> I can use IceCat just fine from the terminal (Guix System),
> more details are needed, ‘I can't run it’ is rather vague.
> Is there any log output, does IceCat start but crash soon,
> maybe ‘bash: icecat: command not found’, ...?
> 
> Greetings,
> Maxime.
> 




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#48796: Guix on Debian 11 - Cant run or find applications from Guix
  2021-06-03 23:18   ` bo0od
@ 2021-06-05  9:47     ` Maxime Devos
  2021-06-05 11:25       ` bo0od
  0 siblings, 1 reply; 7+ messages in thread
From: Maxime Devos @ 2021-06-05  9:47 UTC (permalink / raw)
  To: bo0od, 48796

[-- Attachment #1: Type: text/plain, Size: 1317 bytes --]

bo0od schreef op do 03-06-2021 om 23:18 [+0000]:
>  > Which icon are you looking at? The icon in a desktop menu?
>  > The ‘cat around a globe’ image you'd see on ‘new tab’ windows
>  > above the search bar? The same image, but downscaled, before
>  > ‘New Tab’ in the tab bar?
> 
> There is nothing exist of any kind from icons. (icecat starting icon in 
> the applications menu or so)

For clarification, which option applies?

  (a) IceCat does not appear in the application menu at all
  (b) or:
      IceCat does appear in the application menu, but its icon
      is missing (but there is still some text like ‘GNU IceCat webbrowser’)

>  > I can use IceCat just fine from the terminal (Guix System),
>  > more details are needed, ‘I can't run it’ is rather vague.
>  > Is there any log output, does IceCat start but crash soon,
> 
> I can use that as well fine in guixsd, But not in debian.
> 
>  > maybe ‘bash: icecat: command not found’, ...?
> 
> yes, and if i type ice and press Tab nothing appearing.

What's the output of "echo $PATH"? Normally, $HOME/.guix-profile/bin
should be present in $PATH, but maybe somehow it isn't.

Also, what's the output of
  ls -l ~/.guix-profile/bin/icecat

and
  ls -l ~/.guix-profile/bin
?

Greetings,
Maxime.

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 260 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#48796: Guix on Debian 11 - Cant run or find applications from Guix
  2021-06-05  9:47     ` Maxime Devos
@ 2021-06-05 11:25       ` bo0od
  0 siblings, 0 replies; 7+ messages in thread
From: bo0od @ 2021-06-05 11:25 UTC (permalink / raw)
  To: Maxime Devos, 48796

[-- Attachment #1: Type: text/plain, Size: 1492 bytes --]

 > (a) IceCat does not appear in the application menu at all

This one

 > What's the output of...

Check the uploaded image.

Maxime Devos:
> bo0od schreef op do 03-06-2021 om 23:18 [+0000]:
>>   > Which icon are you looking at? The icon in a desktop menu?
>>   > The ‘cat around a globe’ image you'd see on ‘new tab’ windows
>>   > above the search bar? The same image, but downscaled, before
>>   > ‘New Tab’ in the tab bar?
>>
>> There is nothing exist of any kind from icons. (icecat starting icon in
>> the applications menu or so)
> 
> For clarification, which option applies?
> 
>    (a) IceCat does not appear in the application menu at all
>    (b) or:
>        IceCat does appear in the application menu, but its icon
>        is missing (but there is still some text like ‘GNU IceCat webbrowser’)
> 
>>   > I can use IceCat just fine from the terminal (Guix System),
>>   > more details are needed, ‘I can't run it’ is rather vague.
>>   > Is there any log output, does IceCat start but crash soon,
>>
>> I can use that as well fine in guixsd, But not in debian.
>>
>>   > maybe ‘bash: icecat: command not found’, ...?
>>
>> yes, and if i type ice and press Tab nothing appearing.
> 
> What's the output of "echo $PATH"? Normally, $HOME/.guix-profile/bin
> should be present in $PATH, but maybe somehow it isn't.
> 
> Also, what's the output of
>    ls -l ~/.guix-profile/bin/icecat
> 
> and
>    ls -l ~/.guix-profile/bin
> ?
> 
> Greetings,
> Maxime.
> 

[-- Attachment #2: guixpaths.png --]
[-- Type: image/png, Size: 60221 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#48796: Guix on Debian 11 - Cant run or find applications from Guix
  2021-06-02 18:56 bug#48796: Guix on Debian 11 - Cant run or find applications from Guix bo0od
  2021-06-03 21:26 ` Maxime Devos
@ 2021-06-05 17:49 ` Mark H Weaver
  2021-06-17 14:56   ` Giovanni Biscuolo
  1 sibling, 1 reply; 7+ messages in thread
From: Mark H Weaver @ 2021-06-05 17:49 UTC (permalink / raw)
  To: bo0od, 48796

Hi,

bo0od <bo0od@riseup.net> writes:

> I have installed Guix package manager over debian bullseye 11 then i 
> installed a package using guix (after running guix pull) with two ways: 
> (x package i tried is icecat)
>
> guix install x
>
> sudo -i guix install x
>
> both of the commands worked but the x package has no icon nor i can run 
> it using terminal.

The reason you can't simply type "icecat" in the terminal is because
Guix puts the 'icecat' executable in ~/.guix-profile/bin/icecat, but
that directory is not in your PATH environment variable.

Likewise, the reason there's no icon, i.e. no entry for IceCat in the
list of applications known by desktop environments in Debian, is because
by default desktop environments look in /usr/share/applications for the
".desktop" files, but Guix puts the desktop files in
~/.guix-profile/share/applications.

On a standalone Guix system, these issues are addressed by making sure
your environment variables are set as needed to make these things work.

~/.guix-profile/etc/profile should contain Bash shell commands that set
the environment variables appropriately for the set of packages
currently installed.

If you type "source ~/.guix-profile/etc/profile" from a Bash shell, it
loads the needed environment variable settings into that shell instance,
and henceforth you should be able to run "icecat" by simply typing its
name, *but* _only_ in that shell or other processes later spawned from
that shell.  That's because environment variable settings are _not_
global.  Each process has its own set of environment variable settings.
Typically, newly spawned processes inherit their environment variable
settings from the parent process that launched them.

In order to set your environment variables appropriately for your entire
desktop environment, you must arrange for the environment variable
settings to be loaded before the desktop session is launched.  I don't
remember off-hand how to do this in Debian.  I seem to recall that one
approach is to create an ~/.xsessionrc file, which should be an
executable Bash script that loads the needed environment variable
settings and then launches the desktop environment.  Maybe there's a
better way.

I'm surprised this isn't well-trodden territory, long ago documented in
our manual, but I guess it isn't.  It would be good if some Debian
expert(s), or at least someone who runs Guix on top of Debian, would
step forward to fill in the details.

Thanks for raising this issue.

     Regards,
       Mark

-- 
Disinformation flourishes because many people care deeply about injustice
but very few check the facts.  Ask me about <https://stallmansupport.org>.




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#48796: Guix on Debian 11 - Cant run or find applications from Guix
  2021-06-05 17:49 ` Mark H Weaver
@ 2021-06-17 14:56   ` Giovanni Biscuolo
  0 siblings, 0 replies; 7+ messages in thread
From: Giovanni Biscuolo @ 2021-06-17 14:56 UTC (permalink / raw)
  To: Mark H Weaver, bo0od, 48796

[-- Attachment #1: Type: text/plain, Size: 4897 bytes --]

Hi,

I use Guix on top of Debian, but I installed it long ago "manually" and
not via the Debian package "guix"... anyway once installed there are no
differences :-)

Mark H Weaver <mhw@netris.org> writes:

[...]

>> both of the commands worked but the x package has no icon nor i can run 
>> it using terminal.
>
> The reason you can't simply type "icecat" in the terminal is because
> Guix puts the 'icecat' executable in ~/.guix-profile/bin/icecat, but
> that directory is not in your PATH environment variable.

bo0od please ensure you have this in your ~/.bash_profile:

--8<---------------cut here---------------start------------->8---

GUIX_PROFILE="$HOME/.config/guix/current"
. "$GUIX_PROFILE/etc/profile"

--8<---------------cut here---------------end--------------->8---

Actually, I set all the env variables for Guix in my ~/.profile that
(AFAIU) on Debian is included by default in ~/.bash_profile:

My ~/.bash_profile:

--8<---------------cut here---------------start------------->8---

if [ -f ~/.profile ]; then
    . ~/.profile
fi

--8<---------------cut here---------------end--------------->8---

My (edited) ~/.profile:

--8<---------------cut here---------------start------------->8---

### Guix settings
#
# add Guix current path
export PATH="$HOME/.config/guix/current/bin${PATH:+:}$PATH"
# add Guix infopath
export INFOPATH="$HOME/.config/guix/current/share/info:$INFOPATH"
# Guix locpath
export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale"
# set default Guix profile
export GUIX_PROFILE="$HOME/.guix-profile"
# set Guix extra profiles
export GUIX_EXTRA_PROFILES="$HOME/.guix-extra-profiles"
# set timezone data dir (zoneinfo)
export TZDIR=${GUIX_PROFILE}/share/zoneinfo
# source default Guix profile
. $GUIX_PROFILE/etc/profile

### XDG_CONFIG_DIRS fixes
# see Message-ID: <87r2asweu1.fsf@roquette.mug.biscuolo.net>
unset XDG_CONFIG_DIRS
export XDG_CONFIG_DIRS="${GUIX_PROFILE}/etc/xdg:/etc/xdg"

--8<---------------cut here---------------end--------------->8---

Actually I don't know if all env variables are still really needed, I
need to test things

Also (I don't know why) in my home this two profiles are differing:

--8<---------------cut here---------------start------------->8---

$HOME/.config/guix/current -> /var/guix/profiles/per-user/root/current-guix
$HOME/.guix-profile -> /var/guix/profiles/per-user/giovanni/guix-profile

--8<---------------cut here---------------end--------------->8---

so I'm using my user (giovanni) profile for my GUIX_PROFILE env
variable.

[...]

> That's because environment variable settings are _not_ global.  Each
> process has its own set of environment variable settings.  Typically,
> newly spawned processes inherit their environment variable settings
> from the parent process that launched them.

This is the reason why with Guix installed programs we have to set the
variables for each shell we use:

1. for the bash shell you do this by setting the variables in
~/.bash_profile (or ~/.profile like I'm doing)

> In order to set your environment variables appropriately for your entire
> desktop environment, you must arrange for the environment variable
> settings to be loaded before the desktop session is launched.  I don't
> remember off-hand how to do this in Debian.  I seem to recall that one
> approach is to create an ~/.xsessionrc file,

Yes, AFAIK Mark is right:

2. for the desktop environment (shell) I include ~/.profile in my
~/.xsessionrc (because I like to keep all variables in one place)

My ~/.xsessionrc:

--8<---------------cut here---------------start------------->8---

if [ -f ~/.profile ]; then
    . ~/.profile
fi

--8<---------------cut here---------------end--------------->8---

This way all your xsessions (all X sessions should read ~/.xsessionrc)
will have the right environment (from your default Guix profile) and you
will be able to start Guix installed programs there (i.e. I use i3 for
this and it works well)

For the record, application and icons are sourced by XDG compliant
desktop environment from the XDG_DATA_DIRS env variable, that variable
should be in your default user profile, in
$HOME/.guix-profile/etc/profile, that you should source both in
~/.bash_profile and ~/.xsessionrc as explained above

> which should be an executable Bash script

AFAIU it can be a regular file

[...]

> I'm surprised this isn't well-trodden territory, long ago documented in
> our manual, but I guess it isn't.  It would be good if some Debian
> expert(s), or at least someone who runs Guix on top of Debian, would
> step forward to fill in the details.

I'll try do propose some patch for the Guix manual but... don't hold
your breath, I need some testing.

Happy hacking! Gio'

[...]

-- 
Giovanni Biscuolo

Xelera IT Infrastructures

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 849 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2021-06-17 14:58 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-02 18:56 bug#48796: Guix on Debian 11 - Cant run or find applications from Guix bo0od
2021-06-03 21:26 ` Maxime Devos
2021-06-03 23:18   ` bo0od
2021-06-05  9:47     ` Maxime Devos
2021-06-05 11:25       ` bo0od
2021-06-05 17:49 ` Mark H Weaver
2021-06-17 14:56   ` Giovanni Biscuolo

unofficial mirror of bug-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-bugs/0 guix-bugs/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-bugs guix-bugs/ https://yhetil.org/guix-bugs \
		bug-guix@gnu.org
	public-inbox-index guix-bugs

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.bugs
	nntp://news.gmane.io/gmane.comp.gnu.guix.bugs


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git