unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#18838: zsh test suite failures, possibly due to 'noatime' mount flag
@ 2014-10-26  1:22 Mark H Weaver
  2017-03-17 19:56 ` bug#18838: zsh test suite failures, possible " Joshua Branson
  2020-03-05 10:35 ` bug#18838: zsh test suite failures Vincent Legoll
  0 siblings, 2 replies; 4+ messages in thread
From: Mark H Weaver @ 2014-10-26  1:22 UTC (permalink / raw)
  To: 18838

Twice recently, once on x86_64 and once on i686, zsh has failed its test
suite while being built by hydra.  Here's the output in both cases:

--8<---------------cut here---------------start------------->8---
Test ./C02cond.ztst failed: bad status 1, expected 0 from:
  print -u $ZTST_fd 'This test takes two seconds...'
  sleep 2
  cat unmodified
  touch newnewnew
  if [[ $OSTYPE == "cygwin" ]]; then
    print -u$ZTST_fd "Warning: not testing [[ -N file ]] (not supported on Cygwin)"
    true
  elif [[ "$(find . -prune -fstype nfs 2>/dev/null)" == "." ]]; then
    print -u$ZTST_fd "Warning: not testing [[ -N file ]] (not supported with NFS)"
    true
  elif test -f /etc/mtab && { grep $(df . 2>/dev/null| tail -n1 | awk '{print $1}') /etc/mtab | grep -q noatime; }; then
    print -u$ZTST_fd "Warning: not testing [[ -N file ]] (not supported with noatime file system)"
    true
  else
    [[ -N newnewnew && ! -N unmodified ]]
  fi
Was testing: -N cond
./C02cond.ztst: test failed.
The following may (or may not) help identifying the cause:
  This test can fail on NFS-mounted filesystems as the access and
  modification times are not updated separately.  The test will fail
  on HFS+ (Apple Mac OS X default) filesystems because access times
  are not recorded.  Also, Linux ext3 filesystems may be mounted
  with the noatime option which does not update access times.
  Failures in these cases do not indicate a problem in the shell.
--8<---------------cut here---------------end--------------->8---

I restarted the x86_64 build and it succeeded on the second try.
Now it has failed on i686:

  http://hydra.gnu.org/build/128208

My first guess is that one of our build machines has the 'noatime' mount
option set on its /tmp.

Is there a way to tell from the URL above which build machine was used?

      Mark

^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#18838: zsh test suite failures, possible due to 'noatime' mount flag
  2014-10-26  1:22 bug#18838: zsh test suite failures, possibly due to 'noatime' mount flag Mark H Weaver
@ 2017-03-17 19:56 ` Joshua Branson
  2020-03-05 10:35 ` bug#18838: zsh test suite failures Vincent Legoll
  1 sibling, 0 replies; 4+ messages in thread
From: Joshua Branson @ 2017-03-17 19:56 UTC (permalink / raw)
  To: 18838

This is still an issue.  The last two builds for i686 and arm appear to have been built fine.

But MIPS and x86_64 both have recent failures.

Joshua

^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#18838: zsh test suite failures
  2014-10-26  1:22 bug#18838: zsh test suite failures, possibly due to 'noatime' mount flag Mark H Weaver
  2017-03-17 19:56 ` bug#18838: zsh test suite failures, possible " Joshua Branson
@ 2020-03-05 10:35 ` Vincent Legoll
  2020-10-09 14:57   ` Maxim Cournoyer
  1 sibling, 1 reply; 4+ messages in thread
From: Vincent Legoll @ 2020-03-05 10:35 UTC (permalink / raw)
  To: 18838

Is this still happening?

I searched a bit on ci.guix.gnu.org...

We have a failure on 5.8 armhf (already present on 5.7.1 version)
but it looks like it is a different set of tests that is failing...

-- 
Vincent Legoll

^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#18838: zsh test suite failures
  2020-03-05 10:35 ` bug#18838: zsh test suite failures Vincent Legoll
@ 2020-10-09 14:57   ` Maxim Cournoyer
  0 siblings, 0 replies; 4+ messages in thread
From: Maxim Cournoyer @ 2020-10-09 14:57 UTC (permalink / raw)
  To: Vincent Legoll; +Cc: 18838

Hello,

Vincent Legoll <vincent.legoll@gmail.com> writes:

> Is this still happening?
>
> I searched a bit on ci.guix.gnu.org...
>
> We have a failure on 5.8 armhf (already present on 5.7.1 version)
> but it looks like it is a different set of tests that is failing...

I can't find failures in the raw logs of the last CI failures for
zsh-5.8, but testing on master with:

./pre-inst-env guix build --check --system=armhf-linux zsh

I got 2 test failures:

Test ./A01grammar.ztst failed: bad status 1, expected 0 from:
  - $ZTST_testdir/../Src/zsh -fc "[[ \$0 = \"-$ZTST_testdir/../Src/zsh\" ]]"
Was testing: `-' precommand modifier
./A01grammar.ztst: test failed.
./A02alias.ztst: starting.
This test hangs the shell when it fails...
./A02alias.ztst: all tests successful.
./A03quoting.ztst: starting.
./A03quoting.ztst: all tests successful.
./A04redirect.ztst: starting.
./A04redirect.ztst: all tests successful.
./A05execution.ztst: starting.
Unable to change MONITOR option
This test takes 5 seconds to fail...
Skipping pipe leak test, requires MONITOR option
This test takes 3 seconds and hangs the shell when it fails...
./A05execution.ztst: all tests successful.
./A06assign.ztst: starting.
./A06assign.ztst: all tests successful.
./A07control.ztst: starting.
./A07control.ztst: all tests successful.
./B01cd.ztst: starting.
Test ./B01cd.ztst failed: bad status 0, expected 1 from:
 (unset HOME; ARGV0=sh $ZTST_testdir/../Src/zsh -c cd)
Was testing: Implicit cd with unset HOME.

Maxim




^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-10-09 14:58 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-10-26  1:22 bug#18838: zsh test suite failures, possibly due to 'noatime' mount flag Mark H Weaver
2017-03-17 19:56 ` bug#18838: zsh test suite failures, possible " Joshua Branson
2020-03-05 10:35 ` bug#18838: zsh test suite failures Vincent Legoll
2020-10-09 14:57   ` Maxim Cournoyer

unofficial mirror of bug-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-bugs/0 guix-bugs/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-bugs guix-bugs/ https://yhetil.org/guix-bugs \
		bug-guix@gnu.org
	public-inbox-index guix-bugs

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.bugs
	nntp://news.gmane.io/gmane.comp.gnu.guix.bugs


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git