unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#53157: guix/ui.scm:203 requires guile-3.0.3
@ 2022-01-10 11:37 Efraim Flashner
  2022-01-11 10:14 ` Ludovic Courtès
  0 siblings, 1 reply; 2+ messages in thread
From: Efraim Flashner @ 2022-01-10 11:37 UTC (permalink / raw)
  To: 53157

[-- Attachment #1: Type: text/plain, Size: 1004 bytes --]

I'm using ./pre-inst-env on my powerpc-linux machine, using guile-3.0.2
as provided by Debian. When I try to run the following command:
./pre-inst-env guix build -L /path/to/repo -m /path/to/manifest.scm -n
I get the following error:

guix/ui.scm:230:13: error: default-optimization-level: unbound variable

It doesn't make sense to gate this with (target-ppc32?) since it's due
to the guile version. If I had configured within 'guix shell -D guix' I
would be using guile-3.0.7.

configure.ac checks for guile 3.0.


(ins)efraim@g4:~$ apt-cache policy guile-3.0
guile-3.0:
  Installed: 3.0.2-2be32
  Candidate: 3.0.2-2be32
  Version table:
 *** 3.0.2-2be32 500
        500 http://deb.debian.org/debian-ports sid/main powerpc Packages
        100 /var/lib/dpkg/status


-- 
Efraim Flashner   <efraim@flashner.co.il>   רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* bug#53157: guix/ui.scm:203 requires guile-3.0.3
  2022-01-10 11:37 bug#53157: guix/ui.scm:203 requires guile-3.0.3 Efraim Flashner
@ 2022-01-11 10:14 ` Ludovic Courtès
  0 siblings, 0 replies; 2+ messages in thread
From: Ludovic Courtès @ 2022-01-11 10:14 UTC (permalink / raw)
  To: 53157

Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

> I'm using ./pre-inst-env on my powerpc-linux machine, using guile-3.0.2
> as provided by Debian. When I try to run the following command:
> ./pre-inst-env guix build -L /path/to/repo -m /path/to/manifest.scm -n
> I get the following error:
>
> guix/ui.scm:230:13: error: default-optimization-level: unbound variable
>
> It doesn't make sense to gate this with (target-ppc32?) since it's due
> to the guile version. If I had configured within 'guix shell -D guix' I
> would be using guile-3.0.7.
>
> configure.ac checks for guile 3.0.

I’m in favor of updating ‘configure.ac’ to check for Guile > 3.0.x
(we’ll have to check which value of ‘x’ works).

But…

> (ins)efraim@g4:~$ apt-cache policy guile-3.0
> guile-3.0:
>   Installed: 3.0.2-2be32
>   Candidate: 3.0.2-2be32

… are you saying that requiring > 3.0.2 would cause problems when
porting to other architectures?

In general, we shouldn’t be tied to what Debian provides, but we can see
how much of a problem that would cause.  If it really is a problem, we
can adjust that one reference to ‘default-optimization-level’ in (guix
ui).

Thanks,
Ludo’.




^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2022-01-11 10:16 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-10 11:37 bug#53157: guix/ui.scm:203 requires guile-3.0.3 Efraim Flashner
2022-01-11 10:14 ` Ludovic Courtès

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).