unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#25415: MySQL "server has gone away" when reloading database dump due to "max_allowed_packet" default
@ 2017-01-11  0:10 Ben Sturmfels
  2017-01-12 14:22 ` Ludovic Courtès
  0 siblings, 1 reply; 5+ messages in thread
From: Ben Sturmfels @ 2017-01-11  0:10 UTC (permalink / raw)
  To: 25415

Hi there!

I'm using GuixSD 0.12.0 and ran `guix package --install=mysql` (which
I gather gave me MariaDB 10.1.19), then created a database and tried to
reload a database dump of a decent sized existing database:

  zcat dump.sql.gz | mysql DBNAME

which failed with:

  ERROR 2006 (HY000) at line 2266: MySQL server has gone away

Reloading the same dump works for me on default MySQL in Trisquel 7.
The database dump was created on Debian with `mysqldump --no-create-db
DBNAME`.

On Guix, I was able to reload the dump by running mysqld with a custom
config file with max_allowed_packet=16M under [mysqld].

It appears that the default value for `max_allowed_packet` under
Debian/Trisquel is "16M", where under Guix it is "4M". The mysqldump
defaults bunche a whole lot of records into a single insert statement
for performance, which is why I'm getting a value > 4M.

Could it be worth setting max_allowed_packet to 16M in Guix's
`mysql-configuration-file` function for consistency with Debian?

Regards,
Ben

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#25415: MySQL "server has gone away" when reloading database dump due to "max_allowed_packet" default
  2017-01-11  0:10 bug#25415: MySQL "server has gone away" when reloading database dump due to "max_allowed_packet" default Ben Sturmfels
@ 2017-01-12 14:22 ` Ludovic Courtès
  2017-01-12 23:29   ` Ben Sturmfels
  0 siblings, 1 reply; 5+ messages in thread
From: Ludovic Courtès @ 2017-01-12 14:22 UTC (permalink / raw)
  To: Ben Sturmfels; +Cc: 25415

Hi Ben,

Ben Sturmfels <ben@stumbles.id.au> skribis:

> Reloading the same dump works for me on default MySQL in Trisquel 7.
> The database dump was created on Debian with `mysqldump --no-create-db
> DBNAME`.
>
> On Guix, I was able to reload the dump by running mysqld with a custom
> config file with max_allowed_packet=16M under [mysqld].
>
> It appears that the default value for `max_allowed_packet` under
> Debian/Trisquel is "16M", where under Guix it is "4M". The mysqldump
> defaults bunche a whole lot of records into a single insert statement
> for performance, which is why I'm getting a value > 4M.
>
> Could it be worth setting max_allowed_packet to 16M in Guix's
> `mysql-configuration-file` function for consistency with Debian?

Definitely.  I would add a ‘max-allowed-packet’ field in
<mysql-configuration> in (gnu services databases) and make sure it’s
honored.

Would you like to give it a try?

Thanks for your report!

Ludo’.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#25415: MySQL "server has gone away" when reloading database dump due to "max_allowed_packet" default
  2017-01-12 14:22 ` Ludovic Courtès
@ 2017-01-12 23:29   ` Ben Sturmfels
  2017-01-13  8:03     ` Ludovic Courtès
  2021-09-14 11:51     ` zimoun
  0 siblings, 2 replies; 5+ messages in thread
From: Ben Sturmfels @ 2017-01-12 23:29 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 25415

[-- Attachment #1: Type: text/plain, Size: 697 bytes --]

On 13/01/17 01:22, Ludovic Courtès wrote:

>> Could it be worth setting max_allowed_packet to 16M in Guix's
>> `mysql-configuration-file` function for consistency with Debian?
> 
> Definitely.  I would add a ‘max-allowed-packet’ field in
> <mysql-configuration> in (gnu services databases) and make sure it’s
> honored.
> 
> Would you like to give it a try?

Sure, I'll give it a shot!

It looks as though the MariaDB source comes with a settings file for
Debian that includes max-allowed-packet=16M:

  mariadb-XX.XX.XX/debian/additions/my.cnf

Would you recommend adding just max-allowed-packet, or would it be worth
applying all these settings in this file?

Ben


[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 836 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#25415: MySQL "server has gone away" when reloading database dump due to "max_allowed_packet" default
  2017-01-12 23:29   ` Ben Sturmfels
@ 2017-01-13  8:03     ` Ludovic Courtès
  2021-09-14 11:51     ` zimoun
  1 sibling, 0 replies; 5+ messages in thread
From: Ludovic Courtès @ 2017-01-13  8:03 UTC (permalink / raw)
  To: Ben Sturmfels; +Cc: 25415

Ben Sturmfels <ben@stumbles.id.au> skribis:

> On 13/01/17 01:22, Ludovic Courtès wrote:
>
>>> Could it be worth setting max_allowed_packet to 16M in Guix's
>>> `mysql-configuration-file` function for consistency with Debian?
>> 
>> Definitely.  I would add a ‘max-allowed-packet’ field in
>> <mysql-configuration> in (gnu services databases) and make sure it’s
>> honored.
>> 
>> Would you like to give it a try?
>
> Sure, I'll give it a shot!
>
> It looks as though the MariaDB source comes with a settings file for
> Debian that includes max-allowed-packet=16M:
>
>   mariadb-XX.XX.XX/debian/additions/my.cnf
>
> Would you recommend adding just max-allowed-packet, or would it be worth
> applying all these settings in this file?

I’m not famliar with MySQL/MariaDB, but any setting that sounds useful
to you is welcome.

Thanks,
Ludo’.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#25415: MySQL "server has gone away" when reloading database dump due to "max_allowed_packet" default
  2017-01-12 23:29   ` Ben Sturmfels
  2017-01-13  8:03     ` Ludovic Courtès
@ 2021-09-14 11:51     ` zimoun
  1 sibling, 0 replies; 5+ messages in thread
From: zimoun @ 2021-09-14 11:51 UTC (permalink / raw)
  To: Ben Sturmfels; +Cc: 25415

Hi,

Sorry for the delay about this old bug#25415 [1].

1: <http://issues.guix.gnu.org/issue/25415>

On Fri, 13 Jan 2017 at 10:29, Ben Sturmfels <ben@stumbles.id.au> wrote:
> On 13/01/17 01:22, Ludovic Courtès wrote:
>
>>> Could it be worth setting max_allowed_packet to 16M in Guix's
>>> `mysql-configuration-file` function for consistency with Debian?
>>
>> Definitely.  I would add a ‘max-allowed-packet’ field in
>> <mysql-configuration> in (gnu services databases) and make sure it’s
>> honored.
>>
>> Would you like to give it a try?
>
> Sure, I'll give it a shot!
>
> It looks as though the MariaDB source comes with a settings file for
> Debian that includes max-allowed-packet=16M:
>
>   mariadb-XX.XX.XX/debian/additions/my.cnf
>
> Would you recommend adding just max-allowed-packet, or would it be worth
> applying all these settings in this file?

Well, anything that suits you. :-)  Could you send a patch if it is
relevant?

All the best,
simon




^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-09-14 14:19 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-01-11  0:10 bug#25415: MySQL "server has gone away" when reloading database dump due to "max_allowed_packet" default Ben Sturmfels
2017-01-12 14:22 ` Ludovic Courtès
2017-01-12 23:29   ` Ben Sturmfels
2017-01-13  8:03     ` Ludovic Courtès
2021-09-14 11:51     ` zimoun

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).