unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#22952: MacBook2,1 brightness control requires root privileges
@ 2016-03-08 22:50 Albin
  2016-03-09 13:21 ` bug#22952: MacBook2, 1 " Ludovic Courtès
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Albin @ 2016-03-08 22:50 UTC (permalink / raw)
  To: 22952

Hi,

I've discovered that the non-working brightness controls for the
MacBook2,1 are due to insufficient permissions.

The first indication of this was that I could change brightness by
running the program redshift with root permissions (`sudo redshift`).

Today I was presented with this dialog box in GNOME 3 after having
pressed one of the brightness-control keys:

"Authentication is needed to run
'/gnu/store/[...]-gnome-settings-daemon-3.18.2/libexec/gsd-backlight-helper'
as the super user.

Administrator
Password [__________]"

I tried to input both the user password and the root password but none
of this this had any effect. When I back into GNOME 3 as root, however,
the brightness controls were working.

Does anyone have a suggestion what I could try to give the various
brightness control programs (for GNOME 3, Xfce, etc.) the required
permissions without having to be logged in as root?

Cheers!

Albin

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#22952: MacBook2, 1 brightness control requires root privileges
  2016-03-08 22:50 bug#22952: MacBook2,1 brightness control requires root privileges Albin
@ 2016-03-09 13:21 ` Ludovic Courtès
  2017-04-19 22:23 ` bug#22952: Macbook2,1 " Joshua Branson
  2020-11-17 21:23 ` bug#22952: Backlight brightness keys in GDM and MATE require password authentication pelzflorian (Florian Pelz)
  2 siblings, 0 replies; 7+ messages in thread
From: Ludovic Courtès @ 2016-03-09 13:21 UTC (permalink / raw)
  To: Albin; +Cc: Andy Wingo, 22952

Albin <albin@fripost.org> skribis:

> I've discovered that the non-working brightness controls for the
> MacBook2,1 are due to insufficient permissions.
>
> The first indication of this was that I could change brightness by
> running the program redshift with root permissions (`sudo redshift`).

Interesting.  I use a simple window manager (ratpoison), and ‘redshift’
works fine as non-root.

> Today I was presented with this dialog box in GNOME 3 after having
> pressed one of the brightness-control keys:
>
> "Authentication is needed to run
> '/gnu/store/[...]-gnome-settings-daemon-3.18.2/libexec/gsd-backlight-helper'
> as the super user.
>
> Administrator
> Password [__________]"

This is something Andy is working on:

  https://lists.gnu.org/archive/html/guix-devel/2016-03/msg00247.html

Looks like we’re almost there.  :-)

Ludo’.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#22952: Macbook2,1 brightness control requires root privileges
  2016-03-08 22:50 bug#22952: MacBook2,1 brightness control requires root privileges Albin
  2016-03-09 13:21 ` bug#22952: MacBook2, 1 " Ludovic Courtès
@ 2017-04-19 22:23 ` Joshua Branson
  2017-04-20  8:45   ` bug#22952: Macbook2, 1 " Ludovic Courtès
  2020-11-17 21:23 ` bug#22952: Backlight brightness keys in GDM and MATE require password authentication pelzflorian (Florian Pelz)
  2 siblings, 1 reply; 7+ messages in thread
From: Joshua Branson @ 2017-04-19 22:23 UTC (permalink / raw)
  To: 22952

	I use a Macbook 7,1 and I do not have this issue.

Perhaps this issue is resolved?

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#22952: Macbook2, 1 brightness control requires root privileges
  2017-04-19 22:23 ` bug#22952: Macbook2,1 " Joshua Branson
@ 2017-04-20  8:45   ` Ludovic Courtès
  0 siblings, 0 replies; 7+ messages in thread
From: Ludovic Courtès @ 2017-04-20  8:45 UTC (permalink / raw)
  To: Joshua Branson; +Cc: 22952-done@debbugs.gnu.org

Joshua Branson <bransoj@hotmail.com> skribis:

> 	I use a Macbook 7,1 and I do not have this issue.
>
> Perhaps this issue is resolved?

Indeed, I believe it was fixed about a year ago with the elogind/polkit
integration in GuixSD.

So I’m closing the bug, please reopen if you think it’s not resolved!

Thanks,
Ludo’.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#22952: Backlight brightness keys in GDM and MATE require password authentication
  2016-03-08 22:50 bug#22952: MacBook2,1 brightness control requires root privileges Albin
  2016-03-09 13:21 ` bug#22952: MacBook2, 1 " Ludovic Courtès
  2017-04-19 22:23 ` bug#22952: Macbook2,1 " Joshua Branson
@ 2020-11-17 21:23 ` pelzflorian (Florian Pelz)
  2020-11-18 21:14   ` Marius Bakke
  2 siblings, 1 reply; 7+ messages in thread
From: pelzflorian (Florian Pelz) @ 2020-11-17 21:23 UTC (permalink / raw)
  To: 22952

I’m reopening this bug because it is very similar to my issue.

When using my Macbook’s keyboard XF86MonBrightnessUp/Down keys to
adjust screen brightness (probably on non-Macbooks too) in GDM or
MATE, I am asked to enter my authentication password to make
gnome-settings-daemon’s libexec/gsd-backlight-helper (or some
equivalent program on MATE) change screen brightness.

This should not be so; gsd-backlight-helper should have PolicyKit, pam
or setuid or whatever.

Regards,
Florian




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#22952: Backlight brightness keys in GDM and MATE require password authentication
  2020-11-17 21:23 ` bug#22952: Backlight brightness keys in GDM and MATE require password authentication pelzflorian (Florian Pelz)
@ 2020-11-18 21:14   ` Marius Bakke
  2020-11-19 18:39     ` pelzflorian (Florian Pelz)
  0 siblings, 1 reply; 7+ messages in thread
From: Marius Bakke @ 2020-11-18 21:14 UTC (permalink / raw)
  To: pelzflorian (Florian Pelz), 22952

[-- Attachment #1: Type: text/plain, Size: 894 bytes --]

"pelzflorian (Florian Pelz)" <pelzflorian@pelzflorian.de> skriver:

> I’m reopening this bug because it is very similar to my issue.
>
> When using my Macbook’s keyboard XF86MonBrightnessUp/Down keys to
> adjust screen brightness (probably on non-Macbooks too) in GDM or
> MATE, I am asked to enter my authentication password to make
> gnome-settings-daemon’s libexec/gsd-backlight-helper (or some
> equivalent program on MATE) change screen brightness.
>
> This should not be so; gsd-backlight-helper should have PolicyKit, pam
> or setuid or whatever.

gnome-service-type installs a PolicyKit rule for gnome-settings-daemon.

Should the MATE service do the same?

To work around it locally, try adding:

  (simple-service 'gsd-polkit polkit-service-type
                  (list gnome-settings-daemon))

to the (services ...) section of your system configuration.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 507 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#22952: Backlight brightness keys in GDM and MATE require password authentication
  2020-11-18 21:14   ` Marius Bakke
@ 2020-11-19 18:39     ` pelzflorian (Florian Pelz)
  0 siblings, 0 replies; 7+ messages in thread
From: pelzflorian (Florian Pelz) @ 2020-11-19 18:39 UTC (permalink / raw)
  To: Marius Bakke; +Cc: 22952

On Wed, Nov 18, 2020 at 10:14:32PM +0100, Marius Bakke wrote:
> To work around it locally, try adding:
> 
>   (simple-service 'gsd-polkit polkit-service-type
>                   (list gnome-settings-daemon))
> 
> to the (services ...) section of your system configuration.

Thank you.  You are correct for GDM.  Adding this fixes changing the
backlight in GDM.  Perhaps the GDM service should extend the polkit
service like that.  It also does not conflict with adding a
gnome-service-type.

MATE still complains.  Without changing services, normally both on the
first log-in to MATE and on subsequent log-ins, when pressing the keys
to change the backlight, a message window still tells me that
/gnu/store/5kmmwc9q23lihpy3nv2knbvsr9qv2aln-mate-power-manager-1.24.2/sbin/mate-power-backlight-helper
needs to be authenticated as the super user; I need to enter the
password.

Only with gnome-service-type and when not removing the GDM service,
after GDM (which uses the gsd), on the first log-in to the MATE
desktop, the backlight keys do nothing at all.  When I try to log out,
it says Power Manager is not responding.  When I force the log-out
despite the Power Manager, then log back in, I again get the message
each time I press the backlight keys.

I added:

(simple-service 'mate-power-polkit polkit-service-type
                (list mate-power-manager))

It does not work.

Regards,
Florian




^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2020-11-19 18:42 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-03-08 22:50 bug#22952: MacBook2,1 brightness control requires root privileges Albin
2016-03-09 13:21 ` bug#22952: MacBook2, 1 " Ludovic Courtès
2017-04-19 22:23 ` bug#22952: Macbook2,1 " Joshua Branson
2017-04-20  8:45   ` bug#22952: Macbook2, 1 " Ludovic Courtès
2020-11-17 21:23 ` bug#22952: Backlight brightness keys in GDM and MATE require password authentication pelzflorian (Florian Pelz)
2020-11-18 21:14   ` Marius Bakke
2020-11-19 18:39     ` pelzflorian (Florian Pelz)

unofficial mirror of bug-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-bugs/0 guix-bugs/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-bugs guix-bugs/ https://yhetil.org/guix-bugs \
		bug-guix@gnu.org
	public-inbox-index guix-bugs

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.bugs
	nntp://news.gmane.io/gmane.comp.gnu.guix.bugs


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git