unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#54546: failed to compute the derivation for (very old) Guix
@ 2022-03-24 14:51 Giovanni Biscuolo
  2022-03-24 15:01 ` Maxime Devos
  0 siblings, 1 reply; 7+ messages in thread
From: Giovanni Biscuolo @ 2022-03-24 14:51 UTC (permalink / raw)
  To: 54546

[-- Attachment #1: Type: text/plain, Size: 3401 bytes --]

Hello,

I'm trying to update a (very) old guix installation in my root default
profile

when pulling I'm getting this error:

--8<---------------cut here---------------start------------->8---

$ sudo -i guix pull --url=http://git.savannah.gnu.org/git/guix.git
[sudo] password for g: 
Updating channel 'guix' from Git repository at 'http://git.savannah.gnu.org/git/guix.git'...
Building from this channel:
  guix      http://git.savannah.gnu.org/git/guix.git    ab98b51
Computing Guix derivation for 'x86_64-linux'... \Backtrace:
In ice-9/eval.scm:
   721:20 19 (primitive-eval (define-module (gnu packages racket) #:use-module (guix packages) #:use-module (# #) # ?))
In ice-9/psyntax.scm:
  1235:36 18 (expand-top-sequence ((define-module (gnu packages racket) #:use-module (guix packages) #:use-module ?)) ?)
  1182:24 17 (parse _ (("placeholder" placeholder)) ((top) #(ribcage () () ())) _ e (eval) (hygiene #{ g317}#))
   285:10 16 (parse _ (("placeholder" placeholder)) (()) _ c&e (eval) (hygiene #{ g317}#))
In ice-9/eval.scm:
   293:34 15 (_ #<module (#{ g317}#) 399db40>)
In ice-9/boot-9.scm:
   2874:4 14 (define-module* _ #:filename _ #:pure _ #:version _ #:imports _ #:exports _ #:replacements _ # _ # _ # _ ?)
  2887:24 13 (_)
   222:29 12 (map1 (((guix packages)) ((guix download)) ((guix git-download)) ((guix utils)) ((guix gexp)) ((# ?)) ?))
   222:29 11 (map1 (((guix download)) ((guix git-download)) ((guix utils)) ((guix gexp)) ((guix build-system #)) # ?))
   222:29 10 (map1 (((guix git-download)) ((guix utils)) ((guix gexp)) ((guix build-system copy)) ((guix # gnu)) # ?))
   222:29  9 (map1 (((guix utils)) ((guix gexp)) ((guix build-system copy)) ((guix build-system gnu)) ((srfi #)) # ?))
   222:29  8 (map1 (((guix gexp)) ((guix build-system copy)) ((guix build-system gnu)) ((srfi srfi-1)) ((srfi #)) # ?))
   222:29  7 (map1 (((guix build-system copy)) ((guix build-system gnu)) ((srfi srfi-1)) ((srfi srfi-26)) ((# #)) # ?))
   222:29  6 (map1 (((guix build-system gnu)) ((srfi srfi-1)) ((srfi srfi-26)) ((ice-9 match)) ((ice-9 #)) ((# #)) ?))
   222:29  5 (map1 (((srfi srfi-1)) ((srfi srfi-26)) ((ice-9 match)) ((ice-9 exceptions)) ((gnu packages)) ((# ?)) ?))
   222:29  4 (map1 (((srfi srfi-26)) ((ice-9 match)) ((ice-9 exceptions)) ((gnu packages)) ((gnu packages #)) ((?)) ?))
   222:29  3 (map1 (((ice-9 match)) ((ice-9 exceptions)) ((gnu packages)) ((gnu packages autotools)) ((gnu # #)) # ?))
   222:17  2 (map1 (((ice-9 exceptions)) ((gnu packages)) ((gnu packages autotools)) ((gnu packages bash)) ((# ?)) ?))
   2803:6  1 (resolve-interface _ #:select _ #:hide _ #:prefix _ #:renamer _ #:version _)
In unknown file:
           0 (scm-error misc-error #f "~A ~S" ("no code for module" (ice-9 exceptions)) #f)

ERROR: In procedure scm-error:
no code for module (ice-9 exceptions)
guix pull: error: You found a bug: the program '/gnu/store/7n5xpd211950xyn39sxwqm6jmgishhnv-compute-guix-derivation'
failed to compute the derivation for Guix (version: "ab98b51ef1304e975da127e3092d01dcc7f02657"; system: "x86_64-linux";
host version: "1.0.0"; pull-version: 1).
Please report the COMPLETE output above by email to <bug-guix@gnu.org>.

--8<---------------cut here---------------end--------------->8---

Please is there any workaround for this?

Thanks! Gio'

-- 
Giovanni Biscuolo

Xelera IT Infrastructures

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 849 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#54546: failed to compute the derivation for (very old) Guix
  2022-03-24 14:51 bug#54546: failed to compute the derivation for (very old) Guix Giovanni Biscuolo
@ 2022-03-24 15:01 ` Maxime Devos
  2022-03-24 15:23   ` Giovanni Biscuolo
  0 siblings, 1 reply; 7+ messages in thread
From: Maxime Devos @ 2022-03-24 15:01 UTC (permalink / raw)
  To: Giovanni Biscuolo, 54546

[-- Attachment #1: Type: text/plain, Size: 682 bytes --]

Giovanni Biscuolo schreef op do 24-03-2022 om 15:51 [+0100]:
> --8<---------------cut here---------------end--------------->8---
> [(ice-9 exceptions) stuff]
> Please is there any workaround for this?

build-aux/build-self.scm stubs (gcrypt hash) and (git).
Likewise, it could be modified to stub (ice-9 exceptions) when
'guile-version' refers to a pre-(ice-9 exceptions) Guile.

According to Guile's NEWS, (ice-9 exceptions) is new in 3.0.0,
so the stubbing needs to be made conditional on guile-version<3.0.0.

Additionally, I'm looking into reducing the number of imports and
cycles, so possibly the situation will resolve itself eventually.

Greetings,
Maxime.

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 260 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#54546: failed to compute the derivation for (very old) Guix
  2022-03-24 15:01 ` Maxime Devos
@ 2022-03-24 15:23   ` Giovanni Biscuolo
  2022-03-26 18:09     ` Maxime Devos
  0 siblings, 1 reply; 7+ messages in thread
From: Giovanni Biscuolo @ 2022-03-24 15:23 UTC (permalink / raw)
  To: Maxime Devos, 54546

[-- Attachment #1: Type: text/plain, Size: 1613 bytes --]

Hi Maxime,

Maxime Devos <maximedevos@telenet.be> writes:

> Giovanni Biscuolo schreef op do 24-03-2022 om 15:51 [+0100]:
>> --8<---------------cut here---------------end--------------->8---
>> [(ice-9 exceptions) stuff]
>> Please is there any workaround for this?
>
> build-aux/build-self.scm stubs (gcrypt hash) and (git).
> Likewise, it could be modified to stub (ice-9 exceptions) when
> 'guile-version' refers to a pre-(ice-9 exceptions) Guile.

I get the meaning of "stubbing" but I don't know how to code in Guile,
sorry ? cannot help here

[...]

> Additionally, I'm looking into reducing the number of imports and
> cycles, so possibly the situation will resolve itself eventually.

Meanwhile is there anything I can do to upgrade my guix-damon (on
foreign distro), I never upgraded my root default profile since I first
installed Guix on this machine so now I'm stuck at

--8<---------------cut here---------------start------------->8---

g@renaissance:~$ guix describe -p /var/guix/profiles/per-user/root/current-guix
Generation 1    Jul 20 2020 02:08:33    (current)
g@renaissance:~$ /var/guix/profiles/per-user/root/current-guix/bin/guix-daemon --version
guix-daemon (GNU Guix) 1.0.0

--8<---------------cut here---------------end--------------->8---

This machine is trying to build ungoogled-chromium even if I'm pretty
sure there is a substitute available (installed on another machine with
the very same Guix channel) and I suspect it depends on "something"
related to the guix-daemon


Thanks! Gio'

-- 
Giovanni Biscuolo

Xelera IT Infrastructures

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 849 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#54546: failed to compute the derivation for (very old) Guix
  2022-03-24 15:23   ` Giovanni Biscuolo
@ 2022-03-26 18:09     ` Maxime Devos
  2022-04-07  9:28       ` Giovanni Biscuolo
  2022-06-13 10:30       ` bug#54750: (gnu packages racket) assumes that (ice-9 exceptions) exist, breaks pulling from old Guix Ludovic Courtès
  0 siblings, 2 replies; 7+ messages in thread
From: Maxime Devos @ 2022-03-26 18:09 UTC (permalink / raw)
  To: Giovanni Biscuolo, 54546


[-- Attachment #1.1: Type: text/plain, Size: 1490 bytes --]

Giovanni Biscuolo schreef op do 24-03-2022 om 16:23 [+0100]:
> Hi Maxime,
> 
> Maxime Devos <maximedevos@telenet.be> writes:
> 
> > Giovanni Biscuolo schreef op do 24-03-2022 om 15:51 [+0100]:
> > > --8<---------------cut here---------------end--------------->8---
> > > [(ice-9 exceptions) stuff]
> > > Please is there any workaround for this?
> > 
> > build-aux/build-self.scm stubs (gcrypt hash) and (git).
> > Likewise, it could be modified to stub (ice-9 exceptions) when
> > 'guile-version' refers to a pre-(ice-9 exceptions) Guile.
> 
> I get the meaning of "stubbing" but I don't know how to code in Guile,
> sorry ? cannot help here

Ok, I've tried something in the attached patch (completely untested).

> [...]
> 
> > Additionally, I'm looking into reducing the number of imports and
> > cycles, so possibly the situation will resolve itself eventually.
> 
> Meanwhile is there anything I can do to upgrade my guix-damon (on
> foreign distro)

What guix is the guix service using?  If it's /usr/bin/guix installed
with the foreign distro's package manager, you can do, in case of
Debian, "sudo apt-get update && sudo apt-get upgrade"

> , I never upgraded my root default profile since I first
> installed Guix on this machine so now I'm stuck at [...]

Suggestion: use your regular user's guix to upgrade root's guix:

$ sudo -i "`which guix`" pull 

(this assumes the non-root user has a vaguely up-to-date guix)

Greetings,
Maxime.


[-- Attachment #1.2: Type: text/x-patch, Size: 1619 bytes --]

diff --git a/build-aux/build-self.scm b/build-aux/build-self.scm
index 25a7b1e618..64257bd54c 100644
--- a/build-aux/build-self.scm
+++ b/build-aux/build-self.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021, 2022 Maxime Devos <maximedevos@telenet.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -265,6 +265,9 @@ interface (FFI) of Guile.")
   (define fake-git
     (scheme-file "git.scm" #~(define-module (git))))
 
+  (define fake-ice-9-exceptions
+    (scheme-file "exceptions.scm" #~(define-module (ice-9 exceptions))))
+
   (with-imported-modules `(((guix config)
                             => ,(make-config.scm))
 
@@ -279,6 +282,13 @@ interface (FFI) of Guile.")
                            ;; (git) to placate it.
                            ((git) => ,fake-git)
 
+                           ;; Pre-3.0 versions of Guile don't have (ice-9
+                           ;; exceptions) but (gnu packages racket) imports
+                           ;; it.  Provide a ‘good enough’ (ice-9 exceptions).
+                           ,@(if (string=? "2" (major-version guile-version))
+                                 `(((ice-9 exceptions) ,fake-ice-9-exceptions))
+                                 '())
+
                            ,@(source-module-closure `((guix store)
                                                       (guix self)
                                                       (guix ui)

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 260 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#54546: failed to compute the derivation for (very old) Guix
  2022-03-26 18:09     ` Maxime Devos
@ 2022-04-07  9:28       ` Giovanni Biscuolo
  2022-06-13 10:30       ` bug#54750: (gnu packages racket) assumes that (ice-9 exceptions) exist, breaks pulling from old Guix Ludovic Courtès
  1 sibling, 0 replies; 7+ messages in thread
From: Giovanni Biscuolo @ 2022-04-07  9:28 UTC (permalink / raw)
  To: Maxime Devos, 54546-done

[-- Attachment #1: Type: text/plain, Size: 1686 bytes --]

Hi Maxime,

sorry for this late reply!

I solved my problem with an ugly workaround: installing the Debian
provided guix package and temporarily using that updated daemon in the
systemd service, so I was able to upgrade to an updated Guix (since the
package in Debian is not up to date with upstream)

Maxime Devos <maximedevos@telenet.be> writes:

> Giovanni Biscuolo schreef op do 24-03-2022 om 16:23 [+0100]:

[...]

>> I get the meaning of "stubbing" but I don't know how to code in Guile,
>> sorry ? cannot help here
>
> Ok, I've tried something in the attached patch (completely untested).

Meanwhile I applied the above workaround, I did not test your patch

[...]

>> Meanwhile is there anything I can do to upgrade my guix-damon (on
>> foreign distro)
>
> What guix is the guix service using?

It was version 1.0.0

> If it's /usr/bin/guix installed with the foreign distro's package
> manager, you can do, in case of Debian, "sudo apt-get update && sudo
> apt-get upgrade"

No, I was not using the Debian provided package, I installed from the
upstream Guix binary

>> , I never upgraded my root default profile since I first
>> installed Guix on this machine so now I'm stuck at [...]
>
> Suggestion: use your regular user's guix to upgrade root's guix:
>
> $ sudo -i "`which guix`" pull 
>
> (this assumes the non-root user has a vaguely up-to-date guix)

Wow!  I did not get it before your suggestion! :-O

IMHO this should be the default way to upgrade root's (or any othe user
with an out of date Guix) guix-daemon installation

[...]

Bug closed, thanks! Gio'

-- 
Giovanni Biscuolo

Xelera IT Infrastructures

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 849 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#54750: (gnu packages racket) assumes that (ice-9 exceptions) exist, breaks pulling from old Guix
  2022-03-26 18:09     ` Maxime Devos
  2022-04-07  9:28       ` Giovanni Biscuolo
@ 2022-06-13 10:30       ` Ludovic Courtès
  2022-06-13 10:52         ` bug#54546: " Maxime Devos
  1 sibling, 1 reply; 7+ messages in thread
From: Ludovic Courtès @ 2022-06-13 10:30 UTC (permalink / raw)
  To: Maxime Devos; +Cc: Giovanni Biscuolo, 54750-done, 54546

Hi,

For some reason I had not seen this issue earlier; too bad it remained
for this long.

This is now fixed in 8918ce6d1622303465e716ae491b8e5124c7aece.

Thanks,
Ludo’.




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#54546: bug#54750: (gnu packages racket) assumes that (ice-9 exceptions) exist, breaks pulling from old Guix
  2022-06-13 10:30       ` bug#54750: (gnu packages racket) assumes that (ice-9 exceptions) exist, breaks pulling from old Guix Ludovic Courtès
@ 2022-06-13 10:52         ` Maxime Devos
  0 siblings, 0 replies; 7+ messages in thread
From: Maxime Devos @ 2022-06-13 10:52 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: Giovanni Biscuolo, 54750-done, 54546

[-- Attachment #1: Type: text/plain, Size: 9 bytes --]

Thanks!

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 260 bytes --]

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-06-13 10:53 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-03-24 14:51 bug#54546: failed to compute the derivation for (very old) Guix Giovanni Biscuolo
2022-03-24 15:01 ` Maxime Devos
2022-03-24 15:23   ` Giovanni Biscuolo
2022-03-26 18:09     ` Maxime Devos
2022-04-07  9:28       ` Giovanni Biscuolo
2022-06-13 10:30       ` bug#54750: (gnu packages racket) assumes that (ice-9 exceptions) exist, breaks pulling from old Guix Ludovic Courtès
2022-06-13 10:52         ` bug#54546: " Maxime Devos

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).