unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#51866: OCaml4.07: build fail because Dune version
@ 2021-11-15 12:59 zimoun
  2021-11-15 13:18 ` Julien Lepiller
  0 siblings, 1 reply; 4+ messages in thread
From: zimoun @ 2021-11-15 12:59 UTC (permalink / raw)
  To: 51866

Hi,

These OCaml packages fail to build because some issue with Dune
versions, respectively:

--8<---------------cut here---------------start------------->8---
ocaml4.07-charinfo-width
ocaml4.07-core
ocaml4.07-core-kernel
ocaml4.07-ezjsonm
ocaml4.07-lambda-term
ocaml4.07-merlin
ocaml4.07-odoc
ocaml4.07-piqi
ocaml4.07-piqilib
ocaml4.07-ppx-expect
ocaml4.07-ppx-jane
ocaml4.07-sedlex
ocaml4.07-spawn
ocaml4.07-splittable-random
ocaml4.07-sqlite3
ocaml4.07-uri
ocaml4.07-utop
ocaml4.07-zed
--8<---------------cut here---------------end--------------->8---

fails because:

--8<---------------cut here---------------start------------->8---
Error: Version 2.0 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.7 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.7 of dune is not supported.
Error: Version 2.7 of dune is not supported.
Error: Version 2.7 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.7 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.7 of dune is not supported.
Error: Version 2.0 of dune is not supported.
Error: Version 2.7 of dune is not supported.
Error: Version 2.0 of dune is not supported.
--8<---------------cut here---------------end--------------->8---


From my understanding, more or more cases like this will happen.  The
question is: do we try to fix?  Or do we plan to remove ’ocaml4.07-’
packages?


Cheers,
simon




^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#51866: OCaml4.07: build fail because Dune version
  2021-11-15 12:59 bug#51866: OCaml4.07: build fail because Dune version zimoun
@ 2021-11-15 13:18 ` Julien Lepiller
  2021-11-15 13:30   ` zimoun
  0 siblings, 1 reply; 4+ messages in thread
From: Julien Lepiller @ 2021-11-15 13:18 UTC (permalink / raw)
  To: 51866, zimon.toutoune

[-- Attachment #1: Type: text/plain, Size: 2069 bytes --]

I plan to get rid of ocaml4.07* at some point. For that, I'll need to import a bunch of packages (ocaml-core and friends, at least). Will see if I have enough time for that.

Le 15 novembre 2021 07:59:53 GMT-05:00, zimoun <zimon.toutoune@gmail.com> a écrit :
>Hi,
>
>These OCaml packages fail to build because some issue with Dune
>versions, respectively:
>
>--8<---------------cut here---------------start------------->8---
>ocaml4.07-charinfo-width
>ocaml4.07-core
>ocaml4.07-core-kernel
>ocaml4.07-ezjsonm
>ocaml4.07-lambda-term
>ocaml4.07-merlin
>ocaml4.07-odoc
>ocaml4.07-piqi
>ocaml4.07-piqilib
>ocaml4.07-ppx-expect
>ocaml4.07-ppx-jane
>ocaml4.07-sedlex
>ocaml4.07-spawn
>ocaml4.07-splittable-random
>ocaml4.07-sqlite3
>ocaml4.07-uri
>ocaml4.07-utop
>ocaml4.07-zed
>--8<---------------cut here---------------end--------------->8---
>
>fails because:
>
>--8<---------------cut here---------------start------------->8---
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.7 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.7 of dune is not supported.
>Error: Version 2.7 of dune is not supported.
>Error: Version 2.7 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.7 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.7 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>Error: Version 2.7 of dune is not supported.
>Error: Version 2.0 of dune is not supported.
>--8<---------------cut here---------------end--------------->8---
>
>
>From my understanding, more or more cases like this will happen.  The
>question is: do we try to fix?  Or do we plan to remove ’ocaml4.07-’
>packages?
>
>
>Cheers,
>simon
>
>

[-- Attachment #2: Type: text/html, Size: 2411 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#51866: OCaml4.07: build fail because Dune version
  2021-11-15 13:18 ` Julien Lepiller
@ 2021-11-15 13:30   ` zimoun
  2021-11-19 23:30     ` Julien Lepiller
  0 siblings, 1 reply; 4+ messages in thread
From: zimoun @ 2021-11-15 13:30 UTC (permalink / raw)
  To: Julien Lepiller; +Cc: 51866

Hi,

On lun., 15 nov. 2021 at 08:18, Julien Lepiller <julien@lepiller.eu> wrote:

> I plan to get rid of ocaml4.07* at some point. For that, I'll need to
> import a bunch of packages (ocaml-core and friends, at least). Will
> see if I have enough time for that.

Ok.



> Le 15 novembre 2021 07:59:53 GMT-05:00, zimoun <zimon.toutoune@gmail.com> a écrit :

> These OCaml packages fail to build because some issue with Dune
> versions, respectively:

Considering these packages,

> --8<---------------cut here---------------start------------->8---
> ocaml4.07-charinfo-width
> ocaml4.07-core
> ocaml4.07-core-kernel
> ocaml4.07-ezjsonm
> ocaml4.07-lambda-term
> ocaml4.07-merlin
> ocaml4.07-odoc
> ocaml4.07-piqi
> ocaml4.07-piqilib
> ocaml4.07-ppx-expect
> ocaml4.07-ppx-jane
> ocaml4.07-sedlex
> ocaml4.07-spawn
> ocaml4.07-splittable-random
> ocaml4.07-sqlite3
> ocaml4.07-uri
> ocaml4.07-utop
> ocaml4.07-zed
> --8<---------------cut here---------------end--------------->8---

then “guix refresh -l” says:

--8<---------------cut here---------------start------------->8---
ocaml4.07-charinfo-width Construire le (1) paquet suivant s'assure que les 4 paquets dépendants sont reconstruits : bap@2.0.0
ocaml4.07-core Pas de paquets dépendants autres que lui-même : ocaml4.07-core@0.11.3
ocaml4.07-core-kernel Construire les 2 paquets suivants s'assure que les 2 paquets dépendants sont reconstruits : bap@2.0.0 ocaml4.07-core@0.11.3
ocaml4.07-ezjsonm Un seul paquet dépendant : bap@2.0.0
ocaml4.07-lambda-term Construire le (1) paquet suivant s'assure que les 2 paquets dépendants sont reconstruits : bap@2.0.0
ocaml4.07-merlin Pas de paquets dépendants autres que lui-même : ocaml4.07-merlin@3.2.2
ocaml4.07-odoc Construire les 2 paquets suivants s'assure que les 7 paquets dépendants sont reconstruits : bap@2.0.0 pplacer@1.1.alpha19
ocaml4.07-piqi Un seul paquet dépendant : bap@2.0.0
ocaml4.07-piqilib Construire le (1) paquet suivant s'assure que les 2 paquets dépendants sont reconstruits : bap@2.0.0
ocaml4.07-ppx-expect Construire les 2 paquets suivants s'assure que les 10 paquets dépendants sont reconstruits : ocaml4.07-core@0.11.3 bap@2.0.0
ocaml4.07-ppx-jane Construire les 2 paquets suivants s'assure que les 4 paquets dépendants sont reconstruits : bap@2.0.0 ocaml4.07-core@0.11.3
ocaml4.07-sedlex Construire le (1) paquet suivant s'assure que les 3 paquets dépendants sont reconstruits : bap@2.0.0
ocaml4.07-spawn Un seul paquet dépendant : ocaml4.07-core@0.11.3
ocaml4.07-splittable-random Construire les 2 paquets suivants s'assure que les 3 paquets dépendants sont reconstruits : bap@2.0.0 ocaml4.07-core@0.11.3
ocaml4.07-sqlite3 Un seul paquet dépendant : pplacer@1.1.alpha19
ocaml4.07-uri Un seul paquet dépendant : bap@2.0.0
ocaml4.07-utop Un seul paquet dépendant : bap@2.0.0
ocaml4.07-zed Construire le (1) paquet suivant s'assure que les 3 paquets dépendants sont reconstruits : bap@2.0.0
--8<---------------cut here---------------end--------------->8---

Therefore, it seems safe to remove ocaml4.07-core.  About pplacer,
patch#51351 temporally fixes the issue.  It remains the package ’bap’; I
am not knowledgeable to have an opinion about the remove of such.


1: <http://issues.guix.gnu.org/issue/51351>


Cheers,
simon




^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#51866: OCaml4.07: build fail because Dune version
  2021-11-15 13:30   ` zimoun
@ 2021-11-19 23:30     ` Julien Lepiller
  0 siblings, 0 replies; 4+ messages in thread
From: Julien Lepiller @ 2021-11-19 23:30 UTC (permalink / raw)
  To: zimoun; +Cc: 51866-done

I just pushed fixes to master, so now everything listed in "guix
refresh -l ocaml@4.07" builds without issues. Closing :)




^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-11-19 23:31 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-15 12:59 bug#51866: OCaml4.07: build fail because Dune version zimoun
2021-11-15 13:18 ` Julien Lepiller
2021-11-15 13:30   ` zimoun
2021-11-19 23:30     ` Julien Lepiller

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).