unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
From: raingloom <raingloom@riseup.net>
To: 41927@debbugs.gnu.org
Subject: bug#41927: gio mount unusable on many setups, likely caused by missing dependencies
Date: Wed, 17 Jun 2020 22:58:53 +0200	[thread overview]
Message-ID: <20200617225853.709037fc@riseup.net> (raw)

On machine A which is running i3wm inside the default gdm, i can use
`gio mount` without any issue, with gvfs is installed globally.

On machine B which is running sway inside sddm or without a display
manager, it invariably fails with "volume doesn't implement mount".
Yes, the hostname is correct, yes it can reach it over the network.
Connecting with sshfs works, but gio with the sftp protocol does not.

I tried installing fuse as well, looked for any kind of dependency i
missed, but couldn't find anything. I'm pretty tired and angry that
something that should be trivial doesn't work. I mostly blame GVFS, but
it would be really nice if it was documented somewhere what the hell
people are supposed to install to get their file managers working.

Based on conversations on IRC, others are also having this problem and
they also couldn't find a solution.

Could someone who knows what the hell GVFS is doing help with this? I'd
really like to avoid installing the entirety of Gnome just to mount some
folders.




             reply	other threads:[~2020-06-17 21:56 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-17 20:58 raingloom [this message]
2020-07-01 18:32 ` raingloom
2020-07-02 19:37   ` raingloom

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://guix.gnu.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200617225853.709037fc@riseup.net \
    --to=raingloom@riseup.net \
    --cc=41927@debbugs.gnu.org \
    --subject='Re: bug#41927: gio mount unusable on many setups, likely caused by missing dependencies' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).