In article <87vexjoibu.fsf@laas.fr>, Ludovic Courtès wrote: >Hi, > >The patch below is an attempt to clean up the GC by limiting the use of >global variables for statistics. IMO it makes it easier to read the >code. Furthermore, it's also easier to track the exact number of cells >swept/collected at each stage. > thanks for your patch! > void >-scm_i_adjust_min_yield (scm_t_cell_type_statistics *freelist) >+scm_i_adjust_min_yield (scm_t_cell_type_statistics *freelist, >+ unsigned cells_collected, >+ unsigned cells_swept) you're passing this as a combination everywhere. I think it would be cleaner to create a scm_t_sweep_statistics containing these numbers. Also, you're passing these vars along mostly with with a scm_t_sweep_statistics ptr. Isn't it better to add the collected/swept numbers to that structure? d _______________________________________________ Guile-devel mailing list Guile-devel@gnu.org http://lists.gnu.org/mailman/listinfo/guile-devel