unofficial mirror of guile-devel@gnu.org 
 help / color / mirror / Atom feed
* Names for the C frame stuff
@ 2004-01-07 15:55 Marius Vollmer
  2004-01-10 11:55 ` Dirk Herrmann
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Marius Vollmer @ 2004-01-07 15:55 UTC (permalink / raw)


Hi,

so I'm pondering over how to name the functions that are associated
with the new 'frame' concept.  I'm now mostly convinced to use these
ones:

    scm_frame_begin            - Begin a frame
    scm_frame_end              - End it

    scm_frame_unwind           - Register a unwind handler
    scm_frame_rewind           -          a rewind handler

    scm_frame_block_asyncs     - Block the asyncs
    scm_frame_unblock_asyncs   - Unblock them

    scm_frame_current_input_port
    scm_frame_current_output_port
    scm_frame_current_error_port
                               - Set the indicated port temporarily

    scm_frame_fluid            - Set a fluid temporarily

    etc.

This scheme makes it clear that frames are involved with
scm_frame_block_asyncs (for example) and also gives us enough room for
situations where the nice names are already taken (like
scm_with_fluids).

Comments?


_______________________________________________
Guile-devel mailing list
Guile-devel@gnu.org
http://mail.gnu.org/mailman/listinfo/guile-devel


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Names for the C frame stuff
  2004-01-07 15:55 Names for the C frame stuff Marius Vollmer
@ 2004-01-10 11:55 ` Dirk Herrmann
  2004-01-11  0:19   ` Marius Vollmer
  2004-01-10 16:37 ` Neil Jerram
  2004-01-13 17:33 ` Rob Browning
  2 siblings, 1 reply; 6+ messages in thread
From: Dirk Herrmann @ 2004-01-10 11:55 UTC (permalink / raw)
  Cc: guile-devel

Marius Vollmer wrote:

>so I'm pondering over how to name the functions that are associated
>with the new 'frame' concept.  I'm now mostly convinced to use these
>ones:
>[...]
>  
>
>    scm_frame_unwind           - Register a unwind handler
>    scm_frame_rewind           -          a rewind handler
>
I'd prefer to call these scm_frame_unwind_handler and 
scm_frame_rewind_handler. To me this would make it clearer that you are 
not _doing_ an unwind or a rewind, but are registering a handler for a 
later unwind or rewind. For the rest, I like the naming scheme and the 
names a lot.

Best regards
Dirk Herrmann



_______________________________________________
Guile-devel mailing list
Guile-devel@gnu.org
http://mail.gnu.org/mailman/listinfo/guile-devel


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Names for the C frame stuff
  2004-01-07 15:55 Names for the C frame stuff Marius Vollmer
  2004-01-10 11:55 ` Dirk Herrmann
@ 2004-01-10 16:37 ` Neil Jerram
  2004-01-11  1:25   ` Marius Vollmer
  2004-01-13 17:33 ` Rob Browning
  2 siblings, 1 reply; 6+ messages in thread
From: Neil Jerram @ 2004-01-10 16:37 UTC (permalink / raw)
  Cc: guile-devel

>>>>> "Marius" == Marius Vollmer <marius.vollmer@uni-dortmund.de> writes:

    Marius> Hi,
    Marius> so I'm pondering over how to name the functions that are associated
    Marius> with the new 'frame' concept.  I'm now mostly convinced to use these
    Marius> ones:

    Marius>     scm_frame_begin            - Begin a frame
    Marius>     scm_frame_end              - End it

    Marius>     scm_frame_unwind           - Register a unwind handler
    Marius>     scm_frame_rewind           -          a rewind handler

    Marius>     scm_frame_block_asyncs     - Block the asyncs
    Marius>     scm_frame_unblock_asyncs   - Unblock them

    Marius>     scm_frame_current_input_port
    Marius>     scm_frame_current_output_port
    Marius>     scm_frame_current_error_port
    Marius>                                - Set the indicated port temporarily

    Marius>     scm_frame_fluid            - Set a fluid temporarily

    Marius>     etc.

Sorry to take so long to get back ...  I like the design of this API,
and I also share your concern about flipping the API too much.  In
this case, it seems to me that we can usefully keep
scm_c_call_with_blocked_asyncs etc. both for back compatibility and as
examples of the use of the scm_frame_* API.  (Assuming that the
implementation of scm_c_call_with_blocked_asyncs can be exactly
rewritten to use scm_frame_*.)

Regards,
        Neil



_______________________________________________
Guile-devel mailing list
Guile-devel@gnu.org
http://mail.gnu.org/mailman/listinfo/guile-devel


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Names for the C frame stuff
  2004-01-10 11:55 ` Dirk Herrmann
@ 2004-01-11  0:19   ` Marius Vollmer
  0 siblings, 0 replies; 6+ messages in thread
From: Marius Vollmer @ 2004-01-11  0:19 UTC (permalink / raw)
  Cc: guile-devel

Dirk Herrmann <dirk@dirk-herrmanns-seiten.de> writes:

>>    scm_frame_unwind           - Register a unwind handler
>>    scm_frame_rewind           -          a rewind handler
>>
> I'd prefer to call these scm_frame_unwind_handler and
> scm_frame_rewind_handler.

Yes, that's much better.  I'll change them.

-- 
GPG: D5D4E405 - 2F9B BCCC 8527 692A 04E3  331E FAF8 226A D5D4 E405


_______________________________________________
Guile-devel mailing list
Guile-devel@gnu.org
http://mail.gnu.org/mailman/listinfo/guile-devel


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Names for the C frame stuff
  2004-01-10 16:37 ` Neil Jerram
@ 2004-01-11  1:25   ` Marius Vollmer
  0 siblings, 0 replies; 6+ messages in thread
From: Marius Vollmer @ 2004-01-11  1:25 UTC (permalink / raw)
  Cc: guile-devel

Neil Jerram <neil@ossau.uklinux.net> writes:

> In this case, it seems to me that we can usefully keep
> scm_c_call_with_blocked_asyncs etc. both for back compatibility and
> as examples of the use of the scm_frame_* API.  (Assuming that the
> implementation of scm_c_call_with_blocked_asyncs can be exactly
> rewritten to use scm_frame_*.)

Yes, exactly.  I don't see any reason to remove
scm_c_call_with_blocked_asyncs and other existing functions.

-- 
GPG: D5D4E405 - 2F9B BCCC 8527 692A 04E3  331E FAF8 226A D5D4 E405


_______________________________________________
Guile-devel mailing list
Guile-devel@gnu.org
http://mail.gnu.org/mailman/listinfo/guile-devel


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: Names for the C frame stuff
  2004-01-07 15:55 Names for the C frame stuff Marius Vollmer
  2004-01-10 11:55 ` Dirk Herrmann
  2004-01-10 16:37 ` Neil Jerram
@ 2004-01-13 17:33 ` Rob Browning
  2 siblings, 0 replies; 6+ messages in thread
From: Rob Browning @ 2004-01-13 17:33 UTC (permalink / raw)
  Cc: guile-devel

Marius Vollmer <marius.vollmer@uni-dortmund.de> writes:

>     scm_frame_block_asyncs     - Block the asyncs
>     scm_frame_unblock_asyncs   - Unblock them

That's even better than my suggestion that we might just be fine with
good docs :>

> Comments?

Overall, the names look good to me.

-- 
Rob Browning
rlb @defaultvalue.org and @debian.org; previously @cs.utexas.edu
GPG starting 2002-11-03 = 14DD 432F AE39 534D B592  F9A0 25C8 D377 8C7E 73A4


_______________________________________________
Guile-devel mailing list
Guile-devel@gnu.org
http://mail.gnu.org/mailman/listinfo/guile-devel


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2004-01-13 17:33 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2004-01-07 15:55 Names for the C frame stuff Marius Vollmer
2004-01-10 11:55 ` Dirk Herrmann
2004-01-11  0:19   ` Marius Vollmer
2004-01-10 16:37 ` Neil Jerram
2004-01-11  1:25   ` Marius Vollmer
2004-01-13 17:33 ` Rob Browning

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).