>> -@defun derived-mode-p &rest modes >> +@defun derived-mode-p modes >> This function returns non-@code{nil} if the current major mode is >> derived from any of the major modes given by the symbols @var{modes}. >> +Instead of a list, @var{modes} can also be a single symbol. > > If MODES is supposed to be a list, then why does the first sentence > say "given by the symbols MODES"? Oh, right, in the current text, the `&rest modes` makes it clear that `modes` is a list, whereas with my change we need to spell it out more clearly. > And the last sentence would be a tad less confusing if it said > > Instead of a list, @var{modes} can also be a single mode symbol. Done. >> -(defun provided-mode-derived-p (mode &rest modes) >> +(defun provided-mode-derived-p (mode &optional modes &rest old-modes) >> "Non-nil if MODE is derived from one of MODES. > > This should IMO say > > Non-nil if MODE is derived from a mode that is a member of the list MODES. Changed (tho it now goes over the 72 columns 🙁). >> +(defun derived-mode-p (&optional modes &rest old-modes) >> + "Non-nil if the current major mode is derived from one of MODES. > Likewise here. I'm having trouble making this change fit into the 80 columns limit, so I left this first line unchanged and reworked the second line to clarify that MODES should be a list of symbols. Stefan