On Fri, Jul 19, 2019 at 7:46 AM Eli Zaretskii wrote: > > +static void thaw_hash_tables (void) > > +{ > > This is not our style of defining a function. The name should begin > on a new line. Thanks for pointing that out, revised patch attached. I'm currently playing around with redefining hash tables not to have internal freelists. That makes the hash table code a lot simpler overall, but some of that simplicity would be lost trying to support lazy hash table rehashing.