On Sat, Jul 21, 2018, 11:43 Eli Zaretskii wrote: > > Looks reasonable, thanks. > > > +(defcustom add-log-use-pseudo-changelog t > > + "If non-nil, don't create ChangeLog files for log entries." > > + :type :boolean) > > I frequently find that what we say in the doc string is a very good > hint on how to name the variable. So how about > add-log-don't-create-change-log-file instead? > Fine by me. But even with the apostrophe? > > Also, this needs a :version tag. > Right. 27.1? > > +(defun add-log--pseudo-changelog-buffer-name (changelog-file-name) > > + "Compute suitable name for a pseudo-ChangeLog buffer." > > + (format "*changes to %s*" > > + (abbreviate-file-name > > + (file-name-directory changelog-file-name)))) > > Would the name of the buffer be something like "*changes to ChangeLog*"? > That's awkward, IMO. How about just "*ChangeLog*" instead? > Yeah, that would be pretty awkward, hehe, but it's not what happens, because of the file-name-directory call. > > The above are minor nits, so what else is left that needs to be agreed > upon? > Nothing, afaik. Stefan had said he would probably enhance this later with uniquify support. I'll do the NEWS, should the manual also mention it? João