- I added the prefix "seq-" to all functions - I removed "seq-first" and "seq-rest" - I added "seq-contains-p" and "seq-uniq" - Both new functions are tested - I rewrote "seq-some-p" - "sequences.el" is loaded in "loadup.el" I'm also willing to document these functions in the Elisp manual. Regards, Nico Stefan Monnier writes: >> I understand your point. Then what do you think about having all other >> sequence functions prefixed with "seq-"? > > Yes, you'll want to add seq-* aliases for things like elt. > >> For backward-compatibility, I could keep the current names as aliases, >> and maybe later obsolete them. > > We can start by having seq-elt be an alias for elt (rather than the > other way around) so as not to need changing anything else. > >>> The different of cost between "rest of a list" and "rest of an array" is >>> so large that merging the two this way is probably not a good idea. >> Do you mean that the implementation is lacking in some way or that you >> would remove the "rest" function all together? > > I think it's not just an implementation detail but a fundamental > limitation, so I'd just remove it. Those who really want it can use > subseq (or whatever its new name will be, e.g. seq-subseq). > > Sebastien Vauban writes: >> Why? Isn't it still useful for packages in general (and ELPA in >> particular) so that autoloads files are generated, and these only are >> what's needed to be loaded... allowing performance gains at startup? > > You might as well put a > > ;;;###autoload (require 'seq) > > at that point (or add it to loadup.el). > > > Stefan -- Nicolas Petton http://nicolas-petton.fr