all messages for Emacs-related lists mirrored at yhetil.org
 help / color / mirror / code / Atom feed
From: Nix <nix@esperi.org.uk>
To: Eli Zaretskii <eliz@gnu.org>
Cc: 10617@debbugs.gnu.org
Subject: bug#10617: 24.0.92; Bidi crash reading a message from emacs-devel
Date: Mon, 30 Jan 2012 19:11:55 +0000	[thread overview]
Message-ID: <87wr893szo.fsf@spindle.srvr.nix> (raw)
In-Reply-To: <83r4yhqagl.fsf@gnu.org> (Eli Zaretskii's message of "Mon, 30 Jan 2012 21:03:38 +0200")

On 30 Jan 2012, Eli Zaretskii spake thusly:

> From: Nix <nix@esperi.org.uk>
>> > It would be interesting to see it->current, it->position, it->sp, and
>> > it->string in frames #6 and #8.
>> 
>> Frame 6:
>> 
>> (gdb) print it->current
>> $3 = {
>>   pos = {
>>     charpos = 1430,
>>     bytepos = 1394
>>   },
>>   overlay_string_index = -1,
>>   string_pos = {
>>     charpos = -1,
>>     bytepos = -1
>>   },
>>   dpvec_index = -1
>> }
>> (gdb) print it->position
>> $4 = {
>>   charpos = 1430,
>>   bytepos = 1394
>> }
>
> If bytepos is smaller than charpos, it generally means trouble...

I thought maybe the gap accounted for it -- but this is already
gap-compensated, isn't it? So we have characters of size <1 byte there.
(I sort of doubt that.)

>> (gdb) print it->sp
>> $5 = 0
>> (gdb) print it->string
>> $6 = 12065314
>
> What does "xtype" say about this string?  If it says Lisp_String, what
> does "xstring" say?

(gdb) xtype
Lisp_Symbol
(gdb) xstring
$2 = (struct Lisp_String *) 0xb81a20
There is no member named data.

Not very useful.

(gdb) print *((struct Lisp_String *) 0xb81a20)
$9 = {
  intervals = 0x98,
  u = {
    imm = {
      gcmarkbit = 1,
      immbit = 0,
      size = -40,
      size_byte = -37,
      data = "\204\000\000\000\000\000\"\032\270\000\000\000\000\000\362\031\270\000\000\000\000"
    },
    dat = {
      unused = 1,
      size = <error reading variable>
  }
}

Even less useful.

I'll see if I can reproduce this in an unoptimized build...

-- 
NULL && (void)





  reply	other threads:[~2012-01-30 19:11 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-01-26 22:40 bug#10617: 24.0.92; Bidi crash reading a message from emacs-devel Nix
2012-01-27  9:03 ` Eli Zaretskii
2012-01-30 18:14   ` Nix
2012-01-30 19:03     ` Eli Zaretskii
2012-01-30 19:11       ` Nix [this message]
2012-01-30 19:26         ` Andreas Schwab
2012-01-30 21:09         ` Eli Zaretskii
2012-01-30 21:39           ` Nix
2012-01-31  3:46             ` Eli Zaretskii
2012-01-31 14:21               ` Nix
2012-01-31 16:26                 ` Eli Zaretskii
2012-01-31 18:06                   ` Nix

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87wr893szo.fsf@spindle.srvr.nix \
    --to=nix@esperi.org.uk \
    --cc=10617@debbugs.gnu.org \
    --cc=eliz@gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this external index

	https://git.savannah.gnu.org/cgit/emacs.git
	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.