all messages for Emacs-related lists mirrored at yhetil.org
 help / color / mirror / code / Atom feed
From: Nix <nix@esperi.org.uk>
To: "Stephen J. Turnbull" <stephen@xemacs.org>
Cc: chad <yandros@MIT.EDU>,
	"emacs-devel@gnu.org discussions" <emacs-devel@gnu.org>
Subject: Re: Default for the envelope From in smtpmail.el
Date: Tue, 04 Sep 2012 14:13:24 +0100	[thread overview]
Message-ID: <87a9x6lymj.fsf@spindle.srvr.nix> (raw)
In-Reply-To: <87r4rbmp7u.fsf@uwakimon.sk.tsukuba.ac.jp> (Stephen J. Turnbull's message of "Mon, 13 Aug 2012 12:43:17 +0900")

On 13 Aug 2012, Stephen J. Turnbull stated:
> I suppose it would be possible to enhance user-mail-address to
> something like user-mail-configurations, which would be a list of
> lists like (ADDRESS FULLNAME LOGIN AUTHENTICATION EXTRA-HEADERS).  Of
> course Gnus already supports this kind of thing (I forget the Gnus
> name for the feature, as does VM ("personality crisis").

By coincidence I just had to do exactly that:

,----
| (defvar nix-overriding-smtp-servers '(("nick.alcock@oracle.com" "[work.mailserver.host.censored]" 465 ssl))
|   "List of SMTP servers to override the default with.
| 
| An alist with each element of the form (EMAIL-ADDRESS SMTP-SERVER SMTP-PORT STREAM-TYPE).")
| 
| (defun nix-get-overriding-smtp-servers ()
|   (save-excursion
|     (loop with from = (save-restriction
|                         (message-narrow-to-headers)
|                         (message-fetch-field "from"))
|           for (addr server port stream-type) in nix-overriding-smtp-servers
|           when (string-match addr from) return (list server port stream-type)
|           finally return (list smtpmail-smtp-server smtpmail-smtp-service smtpmail-stream-type))))
| 
| (defadvice smtpmail-via-smtp
|   (around change-smtp-by-message-from-field (recipient buffer &optional ask) activate)
|   (with-current-buffer buffer
|     (progv '(smtpmail-smtp-server smtpmail-smtp-service smtpmail-stream-type)
|         (nix-get-overriding-smtp-servers)
|       ad-do-it)))
`----

Not killingly difficult, but something it would be nice if we didn't
have to do every time.

> IIRC, Glenn was specifically referring to Gnus.  So if he rephrases
> slightly to specify that MUA "personality" customizations should offer
> this option and documentation explaining when it makes sense, I think
> everybody would be happy.

Yes. As seen above, you can do it yourself, but you shouldn't need to,
not really: like gnus-posting-styles, this should be something Gnus (or
message mode) does for you.

-- 
NULL && (void)



  reply	other threads:[~2012-09-04 13:13 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-07-05 15:16 Default for the envelope From in smtpmail.el Lars Magne Ingebrigtsen
2011-07-05 17:16 ` Eli Zaretskii
2011-07-05 19:40   ` Juanma Barranquero
2011-07-05 20:33     ` Eli Zaretskii
2011-07-06  1:30 ` Tim Cross
2012-08-11  1:15 ` Glenn Morris
2012-08-11  6:29   ` Eli Zaretskii
2012-08-11 17:52     ` Glenn Morris
2012-08-11 18:06       ` Glenn Morris
2012-08-12  0:21         ` Rasmus
2012-08-12  0:19       ` Stephen J. Turnbull
2012-08-12  0:42         ` chad
2012-08-12  2:08           ` Glenn Morris
2012-08-12  2:15             ` Glenn Morris
2012-08-12  3:06             ` chad
2012-08-12 15:02               ` Stephen J. Turnbull
2012-08-12 17:38                 ` chad
2012-08-13  3:43                   ` Stephen J. Turnbull
2012-09-04 13:13                     ` Nix [this message]
2012-09-05  1:30                       ` Stephen J. Turnbull
2012-09-05  9:14                         ` Nix
2012-09-04 15:49       ` Lars Ingebrigtsen
2012-09-04 16:01         ` Lars Ingebrigtsen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87a9x6lymj.fsf@spindle.srvr.nix \
    --to=nix@esperi.org.uk \
    --cc=emacs-devel@gnu.org \
    --cc=stephen@xemacs.org \
    --cc=yandros@MIT.EDU \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this external index

	https://git.savannah.gnu.org/cgit/emacs.git
	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.