unofficial mirror of emacs-devel@gnu.org 
 help / color / mirror / code / Atom feed
* Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
@ 2021-04-25 19:51 Uwe Brauer
  2021-04-26 12:05 ` [partially solved] (was: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)) Uwe Brauer
  2021-04-27 13:25 ` Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Stefan Monnier
  0 siblings, 2 replies; 21+ messages in thread
From: Uwe Brauer @ 2021-04-25 19:51 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 1291 bytes --]


Hi 

I just compiled emacs master, commit 
83a915d3dfafd5f3d737afe1e13b75e4dd3aef96

Run just 

 make bootstrap
 make

I did not run 

Run make install


Now when I start emacs from the it from the 

 emacs/src 

Directory

I obtain the following warnings in the shell

,----
| Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
| Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
| Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
| Unable to activate package ‘texfrag’.
| Required package ‘auctex-11.90.2’ is unavailable
| Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
| Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
| Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
| Unable to activate package ‘bibretrieve’.
| Required package ‘auctex-11.87’ is unavailable
| Unable to activate package ‘auctex-latexmk’.
| Required package ‘auctex-11.87’ is unavailable
| 
`----

I find the macro-expansion messages worrying. 

However when I load my init file I receive an error I have never seen
before and which I attach.

Any help would be appreciated, since I like to test the variable 
gnus-registry-register-all
which is a bit recent.

Regards

Uwe Brauer 



[-- Attachment #2: emacs-28bug.txt --]
[-- Type: text/plain, Size: 1643 bytes --]

Debugger entered--Lisp error: (void-variable nonascii-insert-offset)
  eval(nonascii-insert-offset)
  custom-initialize-reset(iso-accents-insert-offset nonascii-insert-offset)
  custom-declare-variable(iso-accents-insert-offset nonascii-insert-offset "Offset added by ISO Accents mode to character code..." :type integer :group iso-acc)
  byte-code("\300\301!\210\302\301\303\304\305\306\307\310&\7\210\311\312\313\314\315\316\307\301&\7\207" [provide iso-acc custom-declare-group nil "Minor mode providing electric accent keys." :prefix "iso-accents-" :group i18n custom-declare-variable iso-accents-insert-offset nonascii-insert-offset "Offset added by ISO Accents mode to character code..." :type integer] 8)
  require(iso-acc)
  eval-buffer(#<buffer  *load*-578047> nil "/home/oub/emacs/init/emacs_init.el" nil t)  ; Reading at buffer position 38760
  load-with-code-conversion("/home/oub/emacs/init/emacs_init.el" "/home/oub/emacs/init/emacs_init.el" nil nil)
  load("/home/oub/emacs/init/emacs_init.el" nil nil t)
  load-file("~/emacs/init/emacs_init.el")
  (cond ((and (not running-xemacs) (> emacs-major-version 19)) (package-initialize) (load-file "~/emacs/init/emacs_init.el") (setq custom-file "/home/oub/emacs/init/custom-init.el") (load-file "/home/oub/emacs/init/custom-init.el")))
  eval-buffer(#<buffer  *load*> nil "/home/oub/.emacs" nil t)  ; Reading at buffer position 904
  load-with-code-conversion("/home/oub/.emacs" "/home/oub/.emacs" nil nil)
  load("/home/oub/.emacs" nil nil t)
  load-file("~/.emacs")
  funcall-interactively(load-file "~/.emacs")
  call-interactively(load-file nil nil)
  command-execute(load-file)

^ permalink raw reply	[flat|nested] 21+ messages in thread

* [partially solved] (was: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset))
  2021-04-25 19:51 Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Uwe Brauer
@ 2021-04-26 12:05 ` Uwe Brauer
  2021-04-26 12:24   ` Eli Zaretskii
  2021-04-26 13:58   ` [partially solved] Stefan Monnier
  2021-04-27 13:25 ` Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Stefan Monnier
  1 sibling, 2 replies; 21+ messages in thread
From: Uwe Brauer @ 2021-04-26 12:05 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 1489 bytes --]

>>> "UB" == Uwe Brauer <oub@mat.ucm.es> writes:

> Hi 

> I just compiled emacs master, commit 
> 83a915d3dfafd5f3d737afe1e13b75e4dd3aef96

> Run just 

>  make bootstrap
>  make

> I did not run 

> Run make install


> Now when I start emacs from the it from the 

>  emacs/src 

> Directory

> I obtain the following warnings in the shell

> ,----
> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
> | Unable to activate package ‘texfrag’.
> | Required package ‘auctex-11.90.2’ is unavailable
> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
> | Unable to activate package ‘bibretrieve’.
> | Required package ‘auctex-11.87’ is unavailable
> | Unable to activate package ‘auctex-latexmk’.
> | Required package ‘auctex-11.87’ is unavailable
> | 
> `----

> I find the macro-expansion messages worrying. 

> However when I load my init file I receive an error I have never seen
> before and which I attach.

I solved this one, it had to do with an ancient version of the iso pkg.
The macro-expansion, I still don't understand but I presume has to do
with certain packages at elpa or melpa

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved] (was: Ubuntu 16.04 compiled GNU master, today,  various problems, macro-expansion and (void-variable nonascii-insert-offset))
  2021-04-26 12:05 ` [partially solved] (was: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)) Uwe Brauer
@ 2021-04-26 12:24   ` Eli Zaretskii
  2021-04-26 13:58   ` [partially solved] Stefan Monnier
  1 sibling, 0 replies; 21+ messages in thread
From: Eli Zaretskii @ 2021-04-26 12:24 UTC (permalink / raw)
  To: Uwe Brauer; +Cc: emacs-devel

> From: Uwe Brauer <oub@mat.ucm.es>
> Date: Mon, 26 Apr 2021 14:05:31 +0200
> 
> > I just compiled emacs master, commit 
> > 83a915d3dfafd5f3d737afe1e13b75e4dd3aef96
> 
> > Run just 
> 
> >  make bootstrap
> >  make
> 
> > I did not run 
> 
> > Run make install
> 
> 
> > Now when I start emacs from the it from the 
> 
> >  emacs/src 
> 
> > Directory
> 
> > I obtain the following warnings in the shell
> 
> > ,----
> > | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> > | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)

Try "make distclean" from the top-level directory, the re-run
configure and Make.



^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-26 12:05 ` [partially solved] (was: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)) Uwe Brauer
  2021-04-26 12:24   ` Eli Zaretskii
@ 2021-04-26 13:58   ` Stefan Monnier
  2021-04-26 14:28     ` Tassilo Horn
                       ` (2 more replies)
  1 sibling, 3 replies; 21+ messages in thread
From: Stefan Monnier @ 2021-04-26 13:58 UTC (permalink / raw)
  To: emacs-devel

>> ,----
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>> | Unable to activate package ‘texfrag’.
>> | Required package ‘auctex-11.90.2’ is unavailable
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>> | Unable to activate package ‘bibretrieve’.
>> | Required package ‘auctex-11.87’ is unavailable
>> | Unable to activate package ‘auctex-latexmk’.
>> | Required package ‘auctex-11.87’ is unavailable
>> | 
>> `----

Any chance you're running a somewhat old AUCTeX version?


        Stefan




^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-26 13:58   ` [partially solved] Stefan Monnier
@ 2021-04-26 14:28     ` Tassilo Horn
  2021-04-26 15:31       ` Stefan Monnier
                         ` (2 more replies)
  2021-04-26 20:41     ` [partially solved] Uwe Brauer
  2021-04-27  6:53     ` [shadchen and lsp-mode] (was: [partially solved]) Uwe Brauer
  2 siblings, 3 replies; 21+ messages in thread
From: Tassilo Horn @ 2021-04-26 14:28 UTC (permalink / raw)
  To: Stefan Monnier; +Cc: emacs-devel

Stefan Monnier <monnier@iro.umontreal.ca> writes:

>>> ,----
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>> | Unable to activate package ‘texfrag’.
>>> | Required package ‘auctex-11.90.2’ is unavailable
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>> | Unable to activate package ‘bibretrieve’.
>>> | Required package ‘auctex-11.87’ is unavailable
>>> | Unable to activate package ‘auctex-latexmk’.
>>> | Required package ‘auctex-11.87’ is unavailable
>>> | 
>>> `----
>
> Any chance you're running a somewhat old AUCTeX version?

When looking at bibretrieve at MELPA

  https://melpa.org/#/bibretrieve

it depends on auctex-11.87 which is from around 2014.  Same for the
auctex-latexmk package from

  https://melpa.org/#/auctex-latexmk

The texfrag package at MELPA

  https://melpa.org/#/texfrag

depends on auctex-11.90.2.  So I guess the auctex versions popping up
there are the minimal versions required by some package.

I know we've had some `make-obsolete' calls where the WHEN argument was
missing which produced a `wrong-number-of-arguments' error in at least
the current emacs master but those are all fixed in auctex 13.0.x (not
sure which x but definitely for x in {8,9}).

Maybe the errors come from something different.  AUCTeX 13 has some
incompatible changes because we've migrated it to `lexical-binding',
possibly including signature changes where there is now a different
arity.

Bye,
Tassilo



^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-26 14:28     ` Tassilo Horn
@ 2021-04-26 15:31       ` Stefan Monnier
  2021-04-26 20:44       ` Uwe Brauer
  2021-04-27  6:21       ` [Some tests] (was: [partially solved]) Uwe Brauer
  2 siblings, 0 replies; 21+ messages in thread
From: Stefan Monnier @ 2021-04-26 15:31 UTC (permalink / raw)
  To: Tassilo Horn; +Cc: emacs-devel

> Stefan Monnier <monnier@iro.umontreal.ca> writes:
>
>>>> ,----
>>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>>> | Unable to activate package ‘texfrag’.
>>>> | Required package ‘auctex-11.90.2’ is unavailable
>>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>>> | Unable to activate package ‘bibretrieve’.
>>>> | Required package ‘auctex-11.87’ is unavailable
>>>> | Unable to activate package ‘auctex-latexmk’.
>>>> | Required package ‘auctex-11.87’ is unavailable
>>>> | 
>>>> `----
>>
>> Any chance you're running a somewhat old AUCTeX version?
>
> When looking at bibretrieve at MELPA
>
>   https://melpa.org/#/bibretrieve
>
> it depends on auctex-11.87 which is from around 2014.  Same for the
> auctex-latexmk package from
>
>   https://melpa.org/#/auctex-latexmk
>
> The texfrag package at MELPA
>
>   https://melpa.org/#/texfrag
>
> depends on auctex-11.90.2.  So I guess the auctex versions popping up
> there are the minimal versions required by some package.
>
> I know we've had some `make-obsolete' calls where the WHEN argument was
> missing which produced a `wrong-number-of-arguments' error in at least
> the current emacs master but those are all fixed in auctex 13.0.x (not
> sure which x but definitely for x in {8,9}).

What I'm thinking is that he has an AUCTeX with those `make-obsolete'
calls, so loading AUCTeX fails with the first 3 errors above, and the
subsequent "Required package ‘auctex-NN.MM’ is unavailable" are
just consequences of that.


        Stefan




^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-26 13:58   ` [partially solved] Stefan Monnier
  2021-04-26 14:28     ` Tassilo Horn
@ 2021-04-26 20:41     ` Uwe Brauer
  2021-04-27  6:53     ` [shadchen and lsp-mode] (was: [partially solved]) Uwe Brauer
  2 siblings, 0 replies; 21+ messages in thread
From: Uwe Brauer @ 2021-04-26 20:41 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 1141 bytes --]

>>> "SM" == Stefan Monnier <monnier@iro.umontreal.ca> writes:

>>> ,----
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>> | Unable to activate package ‘texfrag’.
>>> | Required package ‘auctex-11.90.2’ is unavailable
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>> | Unable to activate package ‘bibretrieve’.
>>> | Required package ‘auctex-11.87’ is unavailable
>>> | Unable to activate package ‘auctex-latexmk’.
>>> | Required package ‘auctex-11.87’ is unavailable
>>> | 
>>> `----

> Any chance you're running a somewhat old AUCTeX version?

Well the auctex version I use (for work) is one I compile from auctex
master.

However, it seems that there some odd pkg dependence that might cause
that trouble.

What do you suggest to solve it?

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-26 14:28     ` Tassilo Horn
  2021-04-26 15:31       ` Stefan Monnier
@ 2021-04-26 20:44       ` Uwe Brauer
  2021-04-27  5:33         ` Tassilo Horn
  2021-04-27  6:21       ` [Some tests] (was: [partially solved]) Uwe Brauer
  2 siblings, 1 reply; 21+ messages in thread
From: Uwe Brauer @ 2021-04-26 20:44 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 2520 bytes --]

>>> "TH" == Tassilo Horn <tsdh@gnu.org> writes:

> Stefan Monnier <monnier@iro.umontreal.ca> writes:
>>> ,----
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>> | Unable to activate package ‘texfrag’.
>>> | Required package ‘auctex-11.90.2’ is unavailable
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>>> | Unable to activate package ‘bibretrieve’.
>>> | Required package ‘auctex-11.87’ is unavailable
>>> | Unable to activate package ‘auctex-latexmk’.
>>> | Required package ‘auctex-11.87’ is unavailable
>>> | 
>>> `----
>> 
>> Any chance you're running a somewhat old AUCTeX version?

> When looking at bibretrieve at MELPA

>   https://melpa.org/#/bibretrieve

> it depends on auctex-11.87 which is from around 2014.  Same for the
> auctex-latexmk package from

>   https://melpa.org/#/auctex-latexmk

> The texfrag package at MELPA

>   https://melpa.org/#/texfrag

> depends on auctex-11.90.2.  So I guess the auctex versions popping up
> there are the minimal versions required by some package.

> I know we've had some `make-obsolete' calls where the WHEN argument was
> missing which produced a `wrong-number-of-arguments' error in at least
> the current emacs master but those are all fixed in auctex 13.0.x (not
> sure which x but definitely for x in {8,9}).

> Maybe the errors come from something different.  AUCTeX 13 has some
> incompatible changes because we've migrated it to `lexical-binding',
> possibly including signature changes where there is now a different
> arity.

As I just in my email to Stefan, the auctex version I actually use, is
compiled from master.

These other one are some dependencies (I am reminded here on my old days
on RPM based packages such as SuSe, before switching to Debian).

So how can I resolve this issue?
What worries me most is 
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)

Hm tomorrow I will try to bisect me init file to see how I can avoid
that message.


[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-26 20:44       ` Uwe Brauer
@ 2021-04-27  5:33         ` Tassilo Horn
  2021-04-27  6:32           ` Uwe Brauer
  2021-04-27  6:43           ` Uwe Brauer
  0 siblings, 2 replies; 21+ messages in thread
From: Tassilo Horn @ 2021-04-27  5:33 UTC (permalink / raw)
  To: Uwe Brauer; +Cc: emacs-devel

Uwe Brauer <oub@mat.ucm.es> writes:

Hi Uwe,

> As I just in my email to Stefan, the auctex version I actually use, is
> compiled from master.

Then the question is how up-to-date that is.  If it's maybe around one
month old, it could be the `make-obsolete' calls I've mentioned.

> These other one are some dependencies (I am reminded here on my old
> days on RPM based packages such as SuSe, before switching to Debian).
>
> So how can I resolve this issue?

Well, when you have packages depending on the auctex package, I guess
they'll pull in the auctex ELPA package, no matter if you have the
auctex git checkout on your `load-path' or not.  So I'd strongly suggest
you use the auctex ELPA package and not the Git version.  I make an ELPA
release from our master after any bug fix anyhow, so it's not that you
would be missing the hot new stuff.

I guess there's also some way to teach package.el that it should assume
some package is already installed in order to stop it from installing
another version due to dependencies but I don't know it from the top of
my head.

Bye,
Tassilo



^ permalink raw reply	[flat|nested] 21+ messages in thread

* [Some tests] (was: [partially solved])
  2021-04-26 14:28     ` Tassilo Horn
  2021-04-26 15:31       ` Stefan Monnier
  2021-04-26 20:44       ` Uwe Brauer
@ 2021-04-27  6:21       ` Uwe Brauer
  2 siblings, 0 replies; 21+ messages in thread
From: Uwe Brauer @ 2021-04-27  6:21 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 1371 bytes --]


> Stefan Monnier <monnier@iro.umontreal.ca> writes:

> When looking at bibretrieve at MELPA

>   https://melpa.org/#/bibretrieve

> it depends on auctex-11.87 which is from around 2014.  Same for the
> auctex-latexmk package from

>   https://melpa.org/#/auctex-latexmk

> The texfrag package at MELPA

>   https://melpa.org/#/texfrag

> depends on auctex-11.90.2.  So I guess the auctex versions popping up
> there are the minimal versions required by some package.

> I know we've had some `make-obsolete' calls where the WHEN argument was
> missing which produced a `wrong-number-of-arguments' error in at least
> the current emacs master but those are all fixed in auctex 13.0.x (not
> sure which x but definitely for x in {8,9}).

> Maybe the errors come from something different.  AUCTeX 13 has some
> incompatible changes because we've migrated it to `lexical-binding',
> possibly including signature changes where there is now a different
> arity.



    1. I manually edited those package and removed the requirement to
       these auctex packages and recompiled. Then I restarted the
       compiled emacs, but it did not help

    2. I have in my emacs init file: package-initialize so I commented
       that also out. Did not help neither. 


I will now uninstall these packages (I basically need only bibretrieve).

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-27  5:33         ` Tassilo Horn
@ 2021-04-27  6:32           ` Uwe Brauer
  2021-04-27  7:00             ` Tassilo Horn
  2021-04-27  6:43           ` Uwe Brauer
  1 sibling, 1 reply; 21+ messages in thread
From: Uwe Brauer @ 2021-04-27  6:32 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 1545 bytes --]

>>> "TH" == Tassilo Horn <tsdh@gnu.org> writes:

> Uwe Brauer <oub@mat.ucm.es> writes:
> Hi Uwe,

>> As I just in my email to Stefan, the auctex version I actually use, is
>> compiled from master.

> Then the question is how up-to-date that is.  If it's maybe around one
> month old, it could be the `make-obsolete' calls I've mentioned.

Right, 19th of march, commit 094c29862190290832e60872c2ab1

So I will pull and recompile

>> These other one are some dependencies (I am reminded here on my old
>> days on RPM based packages such as SuSe, before switching to Debian).
>> 
>> So how can I resolve this issue?

> Well, when you have packages depending on the auctex package, I guess
> they'll pull in the auctex ELPA package, no matter if you have the
> auctex git checkout on your `load-path' or not.  So I'd strongly suggest
> you use the auctex ELPA package and not the Git version.  I make an ELPA
> release from our master after any bug fix anyhow, so it's not that you
> would be missing the hot new stuff.

Right, only when some testing is going on (like with Al's output
features).
What's about these package that require an older version of auctex?

> I guess there's also some way to teach package.el that it should assume
> some package is already installed in order to stop it from installing
> another version due to dependencies but I don't know it from the top of
> my head.

I recall we discussed that somehow in the past (and I did not put the
conclusion in my remember.org file sigh)


[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-27  5:33         ` Tassilo Horn
  2021-04-27  6:32           ` Uwe Brauer
@ 2021-04-27  6:43           ` Uwe Brauer
  1 sibling, 0 replies; 21+ messages in thread
From: Uwe Brauer @ 2021-04-27  6:43 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 1499 bytes --]

>>> "TH" == Tassilo Horn <tsdh@gnu.org> writes:

> Uwe Brauer <oub@mat.ucm.es> writes:
> Hi Uwe,

>> As I just in my email to Stefan, the auctex version I actually use, is
>> compiled from master.

> Then the question is how up-to-date that is.  If it's maybe around one
> month old, it could be the `make-obsolete' calls I've mentioned.

>> These other one are some dependencies (I am reminded here on my old
>> days on RPM based packages such as SuSe, before switching to Debian).
>> 
>> So how can I resolve this issue?

> Well, when you have packages depending on the auctex package, I guess
> they'll pull in the auctex ELPA package, no matter if you have the
> auctex git checkout on your `load-path' or not.  So I'd strongly suggest
> you use the auctex ELPA package and not the Git version.  I make an ELPA
> release from our master after any bug fix anyhow, so it's not that you
> would be missing the hot new stuff.

> I guess there's also some way to teach package.el that it should assume
> some package is already installed in order to stop it from installing
> another version due to dependencies but I don't know it from the top of
> my head.

I found it. I added  file called early-init.el in .emacs.d directory.
That file contains 
(setq package-load-list '((auctex nil) all))
I removed that file, restarted (my old master emacs) and then could
install auctex 13.

However that did not solve the problem, I think I have to bisect my init
file.


[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* [shadchen and lsp-mode] (was: [partially solved])
  2021-04-26 13:58   ` [partially solved] Stefan Monnier
  2021-04-26 14:28     ` Tassilo Horn
  2021-04-26 20:41     ` [partially solved] Uwe Brauer
@ 2021-04-27  6:53     ` Uwe Brauer
  2 siblings, 0 replies; 21+ messages in thread
From: Uwe Brauer @ 2021-04-27  6:53 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 544 bytes --]



> Any chance you're running a somewhat old AUCTeX version?

I checked this now. Auctex in which version whatsoever is not the
culprit. Neither is it my init file, the only candidates I found are 
the lsp-mode and the shadchen mode that are installed in my .emacs.d (by
dependencies) I am unable to uninstall these packages.

I tried to upgrade them lsp-mode did not even compile all its file with
GNU emacs (master from November 2020).

So I now puzzled? Shall I ignore these error message?
How can I uninstall those packages? 

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: [partially solved]
  2021-04-27  6:32           ` Uwe Brauer
@ 2021-04-27  7:00             ` Tassilo Horn
  0 siblings, 0 replies; 21+ messages in thread
From: Tassilo Horn @ 2021-04-27  7:00 UTC (permalink / raw)
  To: Uwe Brauer; +Cc: emacs-devel

Uwe Brauer <oub@mat.ucm.es> writes:

Hi Uwe,

> What's about these package that require an older version of auctex?

They don't actually require old versions but they state just the minimum
version they need, and in effect the current version would be installed.
That is, you couldn't define a package that depends on auctex => 11.87
but smaller than 13.

>> I guess there's also some way to teach package.el that it should assume
>> some package is already installed in order to stop it from installing
>> another version due to dependencies but I don't know it from the top of
>> my head.
>
> I recall we discussed that somehow in the past (and I did not put the
> conclusion in my remember.org file sigh)

Yeah, I think we've talked about that.

Bye,
Tassilo




^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
  2021-04-25 19:51 Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Uwe Brauer
  2021-04-26 12:05 ` [partially solved] (was: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)) Uwe Brauer
@ 2021-04-27 13:25 ` Stefan Monnier
  2021-04-27 20:47   ` Uwe Brauer
  2021-04-27 20:50   ` Uwe Brauer
  1 sibling, 2 replies; 21+ messages in thread
From: Stefan Monnier @ 2021-04-27 13:25 UTC (permalink / raw)
  To: emacs-devel

> I obtain the following warnings in the shell
>
> ,----
> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)

Have you tried `emacs --debug-init`?


        Stefan




^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
  2021-04-27 13:25 ` Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Stefan Monnier
@ 2021-04-27 20:47   ` Uwe Brauer
  2021-04-27 20:50   ` Uwe Brauer
  1 sibling, 0 replies; 21+ messages in thread
From: Uwe Brauer @ 2021-04-27 20:47 UTC (permalink / raw)
  To: Stefan Monnier; +Cc: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 438 bytes --]

>>> "SM" == Stefan Monnier <monnier@iro.umontreal.ca> writes:

>> I obtain the following warnings in the shell
>> 
>> ,----
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)

> Have you tried `emacs --debug-init`?


Ah, no thanks for pointing that out to me.

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
  2021-04-27 13:25 ` Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Stefan Monnier
  2021-04-27 20:47   ` Uwe Brauer
@ 2021-04-27 20:50   ` Uwe Brauer
  2021-04-27 22:29     ` Stefan Monnier
  1 sibling, 1 reply; 21+ messages in thread
From: Uwe Brauer @ 2021-04-27 20:50 UTC (permalink / raw)
  To: Stefan Monnier; +Cc: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 949 bytes --]

>>> "SM" == Stefan Monnier <monnier@iro.umontreal.ca> writes:

>> I obtain the following warnings in the shell
>> 
>> ,----
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)

> Have you tried `emacs --debug-init`?


Did not help, 
/opt/emacs28/bin/emacs --debug-init
Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
 
Then emacs starts no debugging takes place as far as I can see
very odd, the whole thing

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
  2021-04-27 20:50   ` Uwe Brauer
@ 2021-04-27 22:29     ` Stefan Monnier
  2021-04-28 13:37       ` Uwe Brauer
  0 siblings, 1 reply; 21+ messages in thread
From: Stefan Monnier @ 2021-04-27 22:29 UTC (permalink / raw)
  To: Uwe Brauer; +Cc: emacs-devel

>>>> "SM" == Stefan Monnier <monnier@iro.umontreal.ca> writes:
>>> I obtain the following warnings in the shell
>>> ,----
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
>>> | Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>
>> Have you tried `emacs --debug-init`?
>
>
> Did not help, 
> /opt/emacs28/bin/emacs --debug-init
> Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
> Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> Eager macro-expansion failure: (wrong-number-of-arguments (3 . 4) 2)
> Error loading autoloads: (wrong-number-of-arguments (3 . 4) 2)
>  
> Then emacs starts no debugging takes place as far as I can see
> very odd, the whole thing

Hmm... could you `M-x report-emacs-bug`?
Emacs should give you a backtrace in such a situation, I think.


        Stefan




^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
  2021-04-27 22:29     ` Stefan Monnier
@ 2021-04-28 13:37       ` Uwe Brauer
  2021-05-03  1:49         ` Stefan Monnier
  0 siblings, 1 reply; 21+ messages in thread
From: Uwe Brauer @ 2021-04-28 13:37 UTC (permalink / raw)
  To: emacs-devel

[-- Attachment #1: Type: text/plain, Size: 243 bytes --]



> Hmm... could you `M-x report-emacs-bug`?
> Emacs should give you a backtrace in such a situation, I think.

Done, I sent a report but I cannot see any bracktrace it just sent my
configuration at that point (caused by (package-initialize))

[-- Attachment #2: smime.p7s --]
[-- Type: application/pkcs7-signature, Size: 5673 bytes --]

^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
  2021-04-28 13:37       ` Uwe Brauer
@ 2021-05-03  1:49         ` Stefan Monnier
  2021-05-03  1:51           ` Stefan Monnier
  0 siblings, 1 reply; 21+ messages in thread
From: Stefan Monnier @ 2021-05-03  1:49 UTC (permalink / raw)
  To: emacs-devel

>> Hmm... could you `M-x report-emacs-bug`?
>> Emacs should give you a backtrace in such a situation, I think.
>
> Done, I sent a report but I cannot see any bracktrace it just sent my
> configuration at that point (caused by (package-initialize))

I did mean that sending a bug report will give you a backtrace.
I meant that you should report the lack of a backtrace as a bug.


        Stefan




^ permalink raw reply	[flat|nested] 21+ messages in thread

* Re: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)
  2021-05-03  1:49         ` Stefan Monnier
@ 2021-05-03  1:51           ` Stefan Monnier
  0 siblings, 0 replies; 21+ messages in thread
From: Stefan Monnier @ 2021-05-03  1:51 UTC (permalink / raw)
  To: emacs-devel

>>> Hmm... could you `M-x report-emacs-bug`?
>>> Emacs should give you a backtrace in such a situation, I think.
>>
>> Done, I sent a report but I cannot see any bracktrace it just sent my
>> configuration at that point (caused by (package-initialize))
>
> I did mean that sending a bug report will give you a backtrace.
      ^^^
      not

Duh!


        Stefan




^ permalink raw reply	[flat|nested] 21+ messages in thread

end of thread, other threads:[~2021-05-03  1:51 UTC | newest]

Thread overview: 21+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-25 19:51 Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Uwe Brauer
2021-04-26 12:05 ` [partially solved] (was: Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset)) Uwe Brauer
2021-04-26 12:24   ` Eli Zaretskii
2021-04-26 13:58   ` [partially solved] Stefan Monnier
2021-04-26 14:28     ` Tassilo Horn
2021-04-26 15:31       ` Stefan Monnier
2021-04-26 20:44       ` Uwe Brauer
2021-04-27  5:33         ` Tassilo Horn
2021-04-27  6:32           ` Uwe Brauer
2021-04-27  7:00             ` Tassilo Horn
2021-04-27  6:43           ` Uwe Brauer
2021-04-27  6:21       ` [Some tests] (was: [partially solved]) Uwe Brauer
2021-04-26 20:41     ` [partially solved] Uwe Brauer
2021-04-27  6:53     ` [shadchen and lsp-mode] (was: [partially solved]) Uwe Brauer
2021-04-27 13:25 ` Ubuntu 16.04 compiled GNU master, today, various problems, macro-expansion and (void-variable nonascii-insert-offset) Stefan Monnier
2021-04-27 20:47   ` Uwe Brauer
2021-04-27 20:50   ` Uwe Brauer
2021-04-27 22:29     ` Stefan Monnier
2021-04-28 13:37       ` Uwe Brauer
2021-05-03  1:49         ` Stefan Monnier
2021-05-03  1:51           ` Stefan Monnier

unofficial mirror of emacs-devel@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/emacs-devel/0 emacs-devel/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 emacs-devel emacs-devel/ https://yhetil.org/emacs-devel \
		emacs-devel@gnu.org
	public-inbox-index emacs-devel

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.emacs.devel
	nntp://news.gmane.io/gmane.emacs.devel


code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs.git

AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git