From: Nix <nix@esperi.org.uk>
To: David Kastrup <dak@gnu.org>
Cc: emacs-devel@gnu.org
Subject: Re: Move to git is imminent - awaiting Stefan's approval
Date: Sat, 11 Jan 2014 22:34:15 +0000 [thread overview]
Message-ID: <87ob3ijggo.fsf@spindle.srvr.nix> (raw)
In-Reply-To: <871u0kvhv4.fsf@fencepost.gnu.org> (David Kastrup's message of "Mon, 06 Jan 2014 23:57:19 +0100")
On 6 Jan 2014, David Kastrup stated:
> The commit ids are unique. It's usually easiest to quote the entire
> SHA128 via copy&paste, but the first 16 digits or so are usually
> sufficient.
You can just use 'git log --abbrev-commit' to get commit IDs abbreviated
(enough for nonambiguity and no further).
If you want to enable this forever, git 1.7.6+ lets you say
git config log.abbrevCommit true
(add --global or --system to make it apply to all repositories for this
user, or all repositories on the system, respectively).
> In addition, once you have a local repository, something like
>
> git clone existing_workdir new_workdir
>
> will do the cloning by using hard links, taking almost no time and no
> space. I often do that for one-off testing of stuff while my "main"
> workdir is busy compiling stuff.
In addition in addition, git-new-workdir (a script in git's contrib/
directory, likely to be installed by default eventually in some form or
other) will let you check out more than one branch at once on the same
repository.
--
NULL && (void)
next prev parent reply other threads:[~2014-01-11 22:34 UTC|newest]
Thread overview: 101+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-01-06 22:14 Move to git is imminent - awaiting Stefan's approval Angelo Graziosi
2014-01-06 22:57 ` David Kastrup
2014-01-11 22:34 ` Nix [this message]
2014-01-06 23:01 ` Andreas Schwab
2014-01-07 10:24 ` Angelo Graziosi
2014-01-07 10:37 ` Git tips for Emacs development (was Re: Move to git is imminent - awaiting Stefan's approval) Nic Ferrier
2014-01-07 16:05 ` Eli Zaretskii
2014-01-07 12:27 ` Move to git is imminent - awaiting Stefan's approval Sven Axelsson
2014-01-07 14:41 ` Stephen Berman
2014-01-07 14:57 ` Andreas Schwab
2014-01-07 15:05 ` Stephen Berman
2014-01-07 16:25 ` Eli Zaretskii
2014-01-07 16:35 ` Andreas Schwab
2014-01-07 16:37 ` Angelo Graziosi
2014-01-07 16:41 ` Andreas Schwab
2014-01-07 17:08 ` Eli Zaretskii
2014-01-07 17:23 ` Óscar Fuentes
2014-01-07 17:56 ` Eli Zaretskii
2014-01-07 17:24 ` Stephen J. Turnbull
2014-01-07 18:05 ` Eli Zaretskii
2014-01-07 18:17 ` Sven Axelsson
2014-01-07 18:49 ` Stephen J. Turnbull
2014-01-07 19:06 ` Eli Zaretskii
2014-01-08 3:47 ` Stephen J. Turnbull
2014-01-08 15:23 ` Eli Zaretskii
2014-01-07 18:02 ` Thien-Thi Nguyen
2014-01-07 18:06 ` Sven Axelsson
2014-01-07 18:47 ` Andreas Schwab
2014-01-07 19:07 ` Sven Axelsson
2014-01-07 19:16 ` Eli Zaretskii
2014-01-08 3:52 ` Stephen J. Turnbull
2014-01-07 20:08 ` Angelo Graziosi
2014-01-08 17:32 ` Eli Zaretskii
2014-01-08 18:34 ` Andreas Schwab
2014-01-08 18:42 ` Eli Zaretskii
2014-01-08 21:59 ` Angelo Graziosi
2014-01-09 0:05 ` Stefan Monnier
2014-01-09 6:35 ` Eli Zaretskii
2014-01-12 6:27 ` Bob Proulx
2014-01-12 10:11 ` Andreas Schwab
2014-01-12 16:11 ` Eli Zaretskii
2014-01-12 17:09 ` Andreas Schwab
2014-01-12 17:41 ` Eli Zaretskii
2014-01-12 21:13 ` Bob Proulx
2014-01-12 21:24 ` Andreas Schwab
2014-01-13 3:07 ` Bob Proulx
2014-01-15 5:15 ` Bob Proulx
2014-01-12 10:29 ` Achim Gratz
2014-01-12 21:29 ` Bob Proulx
2014-01-12 16:07 ` Eli Zaretskii
2014-01-08 21:55 ` Angelo Graziosi
2014-01-09 19:44 ` Eli Zaretskii
2014-01-07 15:00 ` Angelo Graziosi
2014-01-07 16:17 ` Eli Zaretskii
2014-01-10 6:40 ` Antonio Nikishaev
2014-01-07 12:29 ` David Kastrup
2014-01-07 16:11 ` Eli Zaretskii
2014-01-07 13:37 ` Angelo Graziosi
2014-01-07 14:24 ` Andreas Schwab
2014-01-09 12:18 ` Angelo Graziosi
2014-01-07 16:14 ` Eli Zaretskii
2014-01-07 17:38 ` Rüdiger Sonderfeld
[not found] <<20140106165108.B6BF4380865@snark.thyrsus.com>
[not found] ` <<83zjn9rpaz.fsf@gnu.org>
2014-01-06 17:41 ` Drew Adams
2014-01-06 17:46 ` Eli Zaretskii
-- strict thread matches above, loose matches on Subject: below --
2014-01-06 16:51 Eric S. Raymond
2014-01-06 17:20 ` Jay Belanger
2014-01-06 19:40 ` Eric S. Raymond
2014-01-07 15:57 ` Jay Belanger
2014-01-07 11:20 ` Stephen J. Turnbull
2014-01-07 11:26 ` Eric S. Raymond
2014-01-06 17:30 ` Eli Zaretskii
2014-01-06 21:09 ` Stefan Monnier
2014-01-06 21:29 ` Óscar Fuentes
2014-01-06 23:57 ` Stefan Monnier
2014-01-07 0:17 ` Leo Liu
2014-01-07 5:24 ` Thierry Volpiatto
2014-01-07 13:45 ` Stefan Monnier
2014-01-07 16:22 ` Eli Zaretskii
2014-01-08 21:12 ` Barry Warsaw
2014-01-09 0:04 ` Stefan Monnier
2014-01-09 6:32 ` Eli Zaretskii
2014-01-09 7:32 ` David Engster
2014-01-09 9:46 ` Juanma Barranquero
2014-01-06 17:40 ` Juanma Barranquero
2014-01-06 18:42 ` Bastien
2014-01-06 19:06 ` Jarek Czekalski
2014-01-06 19:37 ` Drew Adams
2014-01-06 19:42 ` Eric S. Raymond
2014-01-06 19:51 ` Drew Adams
2014-01-06 20:25 ` Eric S. Raymond
2014-01-06 20:28 ` Juanma Barranquero
2014-01-07 11:24 ` Stephen J. Turnbull
2014-01-07 2:48 ` joakim
2014-01-07 10:03 ` Andreas Schwab
2014-01-07 10:08 ` joakim
2014-01-15 17:23 ` Martin Geisler
2014-01-15 18:39 ` Stefan Monnier
2014-01-15 22:57 ` Martin Geisler
2014-01-15 23:53 ` Stefan Monnier
2014-01-16 12:25 ` Rüdiger Sonderfeld
2014-01-16 1:40 ` Yuri Khan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
List information: https://www.gnu.org/software/emacs/
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87ob3ijggo.fsf@spindle.srvr.nix \
--to=nix@esperi.org.uk \
--cc=dak@gnu.org \
--cc=emacs-devel@gnu.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
Code repositories for project(s) associated with this public inbox
https://git.savannah.gnu.org/cgit/emacs.git
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).