unofficial mirror of emacs-devel@gnu.org 
 help / color / mirror / code / Atom feed
* More conservative fix for bug#37473 screws my fonts
@ 2022-06-19 17:30 Colin Baxter
  2022-06-19 18:02 ` Colin Baxter
  2022-06-20  0:53 ` Po Lu
  0 siblings, 2 replies; 5+ messages in thread
From: Colin Baxter @ 2022-06-19 17:30 UTC (permalink / raw)
  To: emacs-devel


Hello,

Using emacs-29.0.50, I turn off mode-line proportional fonts via

#+begin_src emacs-lisp
 (cond((= emacs-major-version 29) ;; emacs-29
 (set-face-attribute 'mode-line-active nil :inherit 'mode-line)
 (set-face-attribute 'mode-line-inactive nil :inherit 'mode-line)
 )) ;; End brackets for cond.
#+end_src

and have the setting

#+begin_src emacs-lisp
 '(mode-line ((t (:background "PaleGreen" :foreground "black"
 :weight normal))))
#+end_src

in my theme file. All worked well until commit b2d11d69dd. Now my
mode-line fonts appear to have a light setting weight - they certainly
appear washed out. If I change the weight to bold then they appear too
heavy. If I revert the commit all return to normal.

If we are to have this change, could some information be given as to how
we might return the appearance to what it used to be?

Best wishes,




^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: More conservative fix for bug#37473 screws my fonts
  2022-06-19 17:30 More conservative fix for bug#37473 screws my fonts Colin Baxter
@ 2022-06-19 18:02 ` Colin Baxter
  2022-06-19 18:31   ` Colin Baxter
  2022-06-20  0:53 ` Po Lu
  1 sibling, 1 reply; 5+ messages in thread
From: Colin Baxter @ 2022-06-19 18:02 UTC (permalink / raw)
  To: emacs-devel

>>>>> Colin Baxter <m43cap@yandex.com> writes:

    > Hello,

    > Using emacs-29.0.50, I turn off mode-line proportional fonts via

    > #+begin_src emacs-lisp (cond((= emacs-major-version 29) ;;
    > emacs-29 (set-face-attribute 'mode-line-active nil :inherit
    > 'mode-line) (set-face-attribute 'mode-line-inactive nil :inherit
    > 'mode-line) )) ;; End brackets for cond.  #+end_src


    > and have the setting

    > #+begin_src emacs-lisp '(mode-line ((t (:background "PaleGreen"
    > :foreground "black" :weight normal)))) #+end_src

    > in my theme file. All worked well until commit b2d11d69dd. Now my
    > mode-line fonts appear to have a light setting weight - they
    > certainly appear washed out. If I change the weight to bold then
    > they appear too heavy. If I revert the commit all return to
    > normal.

    > If we are to have this change, could some information be given as
    > to how we might return the appearance to what it used to be?


I have hinting turned off via ~/.font.conf. I may be wrong (I usually
am) but I wonder if the commit has turned hinting back on.



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: More conservative fix for bug#37473 screws my fonts
  2022-06-19 18:02 ` Colin Baxter
@ 2022-06-19 18:31   ` Colin Baxter
  0 siblings, 0 replies; 5+ messages in thread
From: Colin Baxter @ 2022-06-19 18:31 UTC (permalink / raw)
  To: emacs-devel


I see this has been reported to emacs.bugs. Sorry I should have gone
there first.



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: More conservative fix for bug#37473 screws my fonts
  2022-06-19 17:30 More conservative fix for bug#37473 screws my fonts Colin Baxter
  2022-06-19 18:02 ` Colin Baxter
@ 2022-06-20  0:53 ` Po Lu
  2022-06-20  6:01   ` Colin Baxter
  1 sibling, 1 reply; 5+ messages in thread
From: Po Lu @ 2022-06-20  0:53 UTC (permalink / raw)
  To: Colin Baxter; +Cc: emacs-devel

Colin Baxter <m43cap@yandex.com> writes:

> Hello,
>
> Using emacs-29.0.50, I turn off mode-line proportional fonts via
>
>  (cond((= emacs-major-version 29) ;; emacs-29
>  (set-face-attribute 'mode-line-active nil :inherit 'mode-line)
>  (set-face-attribute 'mode-line-inactive nil :inherit 'mode-line)
>  )) ;; End brackets for cond.
>
> and have the setting
>
>  '(mode-line ((t (:background "PaleGreen" :foreground "black"
>  :weight normal))))

FWIW, proportional fonts in the mode-line are already off by default.

> in my theme file. All worked well until commit b2d11d69dd. Now my
> mode-line fonts appear to have a light setting weight - they certainly
> appear washed out. If I change the weight to bold then they appear too
> heavy. If I revert the commit all return to normal.
>
> If we are to have this change, could some information be given as to how
> we might return the appearance to what it used to be?

Does it happen with 37f168afdd too?

I didn't really understand either of the changes, but was trying to fix
a problem on my machine while keeping most of the idea of Lars' code
intact.



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: More conservative fix for bug#37473 screws my fonts
  2022-06-20  0:53 ` Po Lu
@ 2022-06-20  6:01   ` Colin Baxter
  0 siblings, 0 replies; 5+ messages in thread
From: Colin Baxter @ 2022-06-20  6:01 UTC (permalink / raw)
  To: Po Lu; +Cc: emacs-devel

>>>>> Po Lu <luangruo@yahoo.com> writes:

    > Colin Baxter <m43cap@yandex.com> writes:
    >> Hello,
    >> 
    >> Using emacs-29.0.50, I turn off mode-line proportional fonts via
    >> 
    >> (cond((= emacs-major-version 29) ;; emacs-29 (set-face-attribute
    >> 'mode-line-active nil :inherit 'mode-line) (set-face-attribute
    >> 'mode-line-inactive nil :inherit 'mode-line) )) ;; End brackets
    >> for cond.
    >> 
    >> and have the setting
    >> 
    >> '(mode-line ((t (:background "PaleGreen" :foreground "black"
    >> :weight normal))))

    > FWIW, proportional fonts in the mode-line are already off by
    > default.

    >> in my theme file. All worked well until commit b2d11d69dd. Now my
    >> mode-line fonts appear to have a light setting weight - they
    >> certainly appear washed out. If I change the weight to bold then
    >> they appear too heavy. If I revert the commit all return to
    >> normal.
    >> 
    >> If we are to have this change, could some information be given as
    >> to how we might return the appearance to what it used to be?

    > Does it happen with 37f168afdd too?

    > I didn't really understand either of the changes, but was trying
    > to fix a problem on my machine while keeping most of the idea of
    > Lars' code intact.


Hello Po,

Yes, the latest commit 37f168afdd seems to have fixed the problem. My
fonts have returned to normal. Thank you.

Thanks for the information about proportional fonts in the mode-line
been off by default.

Best wishes,



^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2022-06-20  6:01 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-06-19 17:30 More conservative fix for bug#37473 screws my fonts Colin Baxter
2022-06-19 18:02 ` Colin Baxter
2022-06-19 18:31   ` Colin Baxter
2022-06-20  0:53 ` Po Lu
2022-06-20  6:01   ` Colin Baxter

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).