unofficial mirror of emacs-devel@gnu.org 
 help / color / mirror / code / Atom feed
From: Nix <nix@esperi.org.uk>
To: Bruce Korb <bkorb@gnu.org>
Cc: Eli Zaretskii <eliz@gnu.org>, emacs development <emacs-devel@gnu.org>
Subject: Re: Project initialization files?
Date: Sat, 21 Jul 2012 23:06:08 +0100	[thread overview]
Message-ID: <878vecixbj.fsf@spindle.srvr.nix> (raw)
In-Reply-To: <CAKRnqNLarWSFO8PQPZhf2asC+XAsR823g_FCXcEifv37YZrObg@mail.gmail.com> (Bruce Korb's message of "Tue, 17 Jul 2012 13:25:26 -0700")

On 17 Jul 2012, Bruce Korb spake thusly:

> Hi Eli,
>
> On Tue, Jul 17, 2012 at 10:45 AM, Eli Zaretskii <eliz@gnu.org> wrote:
>>> ~/my-day-job, I use the "work" style, etc.
>>>
>>> Does such a thing already exist?
>
>> Is the .dir-locals.el feature (described in the "Specifying File
>> Variables" node of the Emacs manual) fit the bill?  If not, why not?
>
> Only that it entails adding a file to the source tree.

Emacs supports 'directory classes', which let you say things like

(dir-locals-set-directory-class (expand-file-name "~/a/b/c") 'gnu
(dir-locals-set-directory-class (expand-file-name "~/x/y/z") 'linux)
(dir-locals-set-directory-class (expand-file-name "~/foo/bar") 'otbs)

and then you can say e.g.

(dir-locals-set-class-variables
 'gnu '((c-mode . ((c-file-style . "gnu")
                   (fill-column . 80)
                   (sentence-end-double-space . t)
                   (indent-tabs-mode . t)))))

to set variables in each class to your heart's content, without any need
to touch the directories themselves.

-- 
NULL && (void)



  reply	other threads:[~2012-07-21 22:06 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-17 17:25 Project initialization files? Bruce Korb
2012-07-17 17:45 ` Eli Zaretskii
2012-07-17 20:25   ` Bruce Korb
2012-07-21 22:06     ` Nix [this message]
2012-07-17 21:12   ` Dan Nicolaescu
2012-07-17 18:17 ` Jambunathan K

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://www.gnu.org/software/emacs/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=878vecixbj.fsf@spindle.srvr.nix \
    --to=nix@esperi.org.uk \
    --cc=bkorb@gnu.org \
    --cc=eliz@gnu.org \
    --cc=emacs-devel@gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/emacs.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).