On 04/03/2014 12:30 PM, Eli Zaretskii wrote: > +/* Find number of elements in array */ > +#define EARRAYSIZE(arr) (sizeof (arr) / sizeof ((arr)[0])) > > I find the name of this macro to be unfortunate: what it returns is > not "size" in the accepted meaning of that word. "Length", "size", and "count" are hopelessly confounded anyway. I'm not attached to any particular term: I chose EARRAYSIZE because ARRAYSIZE and ARRAY_SIZE hace been common in other projects I've worked on. > How about ALEN, or ARRAYELTS instead? Of these, I prefer ARRAYELTS. I'll change the name.