Alan Third writes: > Thanks! This looks much better than what we had before. No crashes for > one! > > A few nitpicks: > >> + BOOL is_fullscreen_transition; > > I may be misunderstanding this, but would ‘in_fullscreen_transition’ > be a better name? OK, renamed. > Opening braces go on a new line. Braces style is fixed to match Emacs code style. > And again. That ‘} else {’ should also be over three lines. > >> #if MAC_OS_X_VERSION_MIN_REQUIRED < 1070 >> @@ -7932,9 +7998,14 @@ - (void)toggleFullScreen: (id)sender >> { >> #if defined (NS_IMPL_COCOA) && MAC_OS_X_VERSION_MAX_ALLOWED >= 1070 >> #if MAC_OS_X_VERSION_MIN_REQUIRED < 1070 >> - if ([[self window] respondsToSelector: @selector(toggleFullScreen:)]) >> + if ([[self window] respondsToSelector: @selector(toggleFullScreen:)]){ >> #endif >> [[self window] toggleFullScreen:sender]; >> + // wait for fullscreen animation complete (bug#28496) >> + [self waitFullScreenTransition]; >> +#endif >> +#if MAC_OS_X_VERSION_MIN_REQUIRED < 1070 >> + } >> #endif >> return; >> } > > Should that final #if #endif not be within the outer #if #endif? Yes. Fixed. Thanks! Please see attached patch. Log message is also provided.