> Please just call it WINDOW_FRAME_SCALE_FACTOR or FRAME_SCALE_FACTOR. > WINDOW_SCALE_FACTOR implies that it could be different for different > windows on the same frame. Good point, I've changed the name to WINDOW_FRAME_SCALE_FACTOR. I've a bad feeling towards the conditional hidden behind that macro, though. It's necessary because WINDOW_LEFT/RIGHT_FRINGE_WIDTH are being called in contexts where the rif is still unavailable; so knowing of no other sensible default, I just defaulted to 1. Now, there is a bad smell in these requests for geometry parameters in places where the exact geometry may still be unknown (although I believe geometry is indeed known because, even if there isn't a rif, cursory debugging shows that there already is a frame in all problematic cases). So either these usages asume geometry is not dependent on the current screen or, less problematically and more probably, the rif is being initialized too late. A careful inspection of every use place is a lot of work (I might be doing some of it next weekend, though) so for now I'm just returning a sane default so that we can safely move forward.